summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debian/rules/debhelper-no-depends/build-spec
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
commit75808db17caf8b960b351e3408e74142f4c85aac (patch)
tree7989e9c09a4240248bf4658a22208a0a52d991c4 /t/recipes/checks/debian/rules/debhelper-no-depends/build-spec
parentInitial commit. (diff)
downloadlintian-75808db17caf8b960b351e3408e74142f4c85aac.tar.xz
lintian-75808db17caf8b960b351e3408e74142f4c85aac.zip
Adding upstream version 2.117.0.upstream/2.117.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 't/recipes/checks/debian/rules/debhelper-no-depends/build-spec')
-rw-r--r--t/recipes/checks/debian/rules/debhelper-no-depends/build-spec/debian/compat.in1
-rw-r--r--t/recipes/checks/debian/rules/debhelper-no-depends/build-spec/debian/control.in33
-rwxr-xr-xt/recipes/checks/debian/rules/debhelper-no-depends/build-spec/debian/rules24
-rw-r--r--t/recipes/checks/debian/rules/debhelper-no-depends/build-spec/fill-values5
4 files changed, 63 insertions, 0 deletions
diff --git a/t/recipes/checks/debian/rules/debhelper-no-depends/build-spec/debian/compat.in b/t/recipes/checks/debian/rules/debhelper-no-depends/build-spec/debian/compat.in
new file mode 100644
index 0000000..640a566
--- /dev/null
+++ b/t/recipes/checks/debian/rules/debhelper-no-depends/build-spec/debian/compat.in
@@ -0,0 +1 @@
+[% $dh_compat_level %]
diff --git a/t/recipes/checks/debian/rules/debhelper-no-depends/build-spec/debian/control.in b/t/recipes/checks/debian/rules/debhelper-no-depends/build-spec/debian/control.in
new file mode 100644
index 0000000..6a7a04d
--- /dev/null
+++ b/t/recipes/checks/debian/rules/debhelper-no-depends/build-spec/debian/control.in
@@ -0,0 +1,33 @@
+Source: [% $source %]
+Priority: optional
+Section: [% $section %]
+Maintainer: [% $author %]
+Standards-Version: [% $standards_version %]
+Rules-Requires-Root: no
+
+Package: [% $source %]
+Architecture: [% $package_architecture %]
+Description: [% $description %]
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+
+Package: debhelper-pre-depends
+Architecture: [% $package_architecture %]
+Pre-Depends: ${misc:Depends}
+Description: [% $description %] extra string
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. Extra
+ string to not to trigger duplicated description tags. It may
+ be an empty package.
+
+Package: debhelper-suggests
+Architecture: [% $package_architecture %]
+Suggests: ${misc:Depends}
+Description: [% $description %] another extra string
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. Extra
+ string. It may be an empty package.
diff --git a/t/recipes/checks/debian/rules/debhelper-no-depends/build-spec/debian/rules b/t/recipes/checks/debian/rules/debhelper-no-depends/build-spec/debian/rules
new file mode 100755
index 0000000..a622013
--- /dev/null
+++ b/t/recipes/checks/debian/rules/debhelper-no-depends/build-spec/debian/rules
@@ -0,0 +1,24 @@
+#!/usr/bin/make -f
+%:
+ dh $@
+
+binary: binary-arch binary-indep
+binary-arch:
+binary-indep:
+ -dh_clideps
+ -dh_gstscancodecs
+ dh_lisp || true
+ # Should trigger a versioned dependency requirement for dpatch
+ -dh_dpatch_patch
+# We don't warn about commands inside make conditionals, so none of these
+# get any warnings.
+ifeq "$(USE_DH_PYTHON3)" "y"
+ dh_python3
+else
+ ifeq "$(USE_PYSUPPORT)" "y"
+ dh_pysupport
+ endif
+endif
+ dh binary-indep
+ -dh_strip_nondeterminism
+ -dh_scour
diff --git a/t/recipes/checks/debian/rules/debhelper-no-depends/build-spec/fill-values b/t/recipes/checks/debian/rules/debhelper-no-depends/build-spec/fill-values
new file mode 100644
index 0000000..7857128
--- /dev/null
+++ b/t/recipes/checks/debian/rules/debhelper-no-depends/build-spec/fill-values
@@ -0,0 +1,5 @@
+Skeleton: upload-native
+Testname: debhelper-no-depends
+Dh-Compat-Level: 9
+Description: Test dependency requirements for debhelper
+# Overrides the "data/debhelper/compat-level"