summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
commit75808db17caf8b960b351e3408e74142f4c85aac (patch)
tree7989e9c09a4240248bf4658a22208a0a52d991c4 /t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe
parentInitial commit. (diff)
downloadlintian-75808db17caf8b960b351e3408e74142f4c85aac.tar.xz
lintian-75808db17caf8b960b351e3408e74142f4c85aac.zip
Adding upstream version 2.117.0.upstream/2.117.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 't/recipes/checks/files/symbolic-links/broken/symlinks-unsafe')
-rw-r--r--t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/build-spec/debian/rules14
-rw-r--r--t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/build-spec/fill-values3
-rw-r--r--t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/eval/desc2
-rw-r--r--t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/eval/hints2
4 files changed, 21 insertions, 0 deletions
diff --git a/t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/build-spec/debian/rules b/t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/build-spec/debian/rules
new file mode 100644
index 0000000..c2b7e3c
--- /dev/null
+++ b/t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/build-spec/debian/rules
@@ -0,0 +1,14 @@
+#!/usr/bin/make -f
+
+PKG:=$(shell dh_listpackages)
+LINK_DIR:=debian/$(PKG)/usr/share/lintian/bad-links
+LINK_TARGET:=non-existent/path/lintian-should-not-open
+
+%:
+ dh $@
+
+override_dh_link:
+ mkdir -p "$(LINK_DIR)"
+ ln -s ../../../../../$(LINK_TARGET) \
+ $(LINK_DIR)/relative-escape
+ ln -s /../$(LINK_TARGET) $(LINK_DIR)/absolute
diff --git a/t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/build-spec/fill-values b/t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/build-spec/fill-values
new file mode 100644
index 0000000..da87d48
--- /dev/null
+++ b/t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: symlinks-unsafe
+Description: General tests of unsafe symlinks
diff --git a/t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/eval/desc b/t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/eval/desc
new file mode 100644
index 0000000..0784410
--- /dev/null
+++ b/t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/eval/desc
@@ -0,0 +1,2 @@
+Testname: symlinks-unsafe
+Check: files/symbolic-links/broken
diff --git a/t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/eval/hints b/t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/eval/hints
new file mode 100644
index 0000000..9285ab9
--- /dev/null
+++ b/t/recipes/checks/files/symbolic-links/broken/symlinks-unsafe/eval/hints
@@ -0,0 +1,2 @@
+symlinks-unsafe (binary): package-contains-unsafe-symlink [usr/share/lintian/bad-links/relative-escape]
+symlinks-unsafe (binary): package-contains-unsafe-symlink [usr/share/lintian/bad-links/absolute]