summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
commit75808db17caf8b960b351e3408e74142f4c85aac (patch)
tree7989e9c09a4240248bf4658a22208a0a52d991c4 /t/recipes/checks/languages/python/files-python-module-has-overly-generic-name
parentInitial commit. (diff)
downloadlintian-75808db17caf8b960b351e3408e74142f4c85aac.tar.xz
lintian-75808db17caf8b960b351e3408e74142f4c85aac.zip
Adding upstream version 2.117.0.upstream/2.117.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 't/recipes/checks/languages/python/files-python-module-has-overly-generic-name')
-rw-r--r--t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/debian/control.in16
-rw-r--r--t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/debian/install9
-rw-r--r--t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/debian/rules5
-rw-r--r--t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/fill-values3
-rw-r--r--t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/orig/__init__.py0
-rw-r--r--t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/orig/site.py0
-rw-r--r--t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/orig/tests.py0
-rw-r--r--t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/eval/desc4
-rw-r--r--t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/eval/hints9
9 files changed, 46 insertions, 0 deletions
diff --git a/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/debian/control.in b/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/debian/control.in
new file mode 100644
index 0000000..29bb9c6
--- /dev/null
+++ b/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/debian/control.in
@@ -0,0 +1,16 @@
+Source: [% $source %]
+Priority: optional
+Section: python
+Maintainer: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %]
+Rules-Requires-Root: no
+
+Package: python3-foo
+Architecture: [% $package_architecture %]
+Depends: ${misc:Depends},
+Description: [% $description %]
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
diff --git a/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/debian/install b/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/debian/install
new file mode 100644
index 0000000..ddf8315
--- /dev/null
+++ b/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/debian/install
@@ -0,0 +1,9 @@
+site.py /usr/lib/python3/dist-packages
+tests.py /usr/lib/python3/dist-packages
+__init__.py /usr/lib/python3/dist-packages/doc/
+__init__.py /usr/lib/python3/dist-packages/docs/
+__init__.py /usr/lib/python3/dist-packages/test/
+__init__.py /usr/lib/python3/dist-packages/tests/
+__init__.py /usr/lib/python3/dist-packages/example/
+__init__.py /usr/lib/python3/dist-packages/examples/
+__init__.py /usr/lib/python3/dist-packages/false_positive/
diff --git a/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/debian/rules b/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/debian/rules
new file mode 100644
index 0000000..abde6ef
--- /dev/null
+++ b/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/debian/rules
@@ -0,0 +1,5 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
diff --git a/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/fill-values b/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/fill-values
new file mode 100644
index 0000000..57ceb09
--- /dev/null
+++ b/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: files-python-module-has-overly-generic-name
+Description: Test tags for Python modules with overly generic names
diff --git a/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/orig/__init__.py b/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/orig/__init__.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/orig/__init__.py
diff --git a/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/orig/site.py b/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/orig/site.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/orig/site.py
diff --git a/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/orig/tests.py b/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/orig/tests.py
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/build-spec/orig/tests.py
diff --git a/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/eval/desc b/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/eval/desc
new file mode 100644
index 0000000..e2c469a
--- /dev/null
+++ b/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/eval/desc
@@ -0,0 +1,4 @@
+Testname: files-python-module-has-overly-generic-name
+Test-Against:
+ unknown-file-in-python-module-directory
+Check: languages/python
diff --git a/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/eval/hints b/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/eval/hints
new file mode 100644
index 0000000..b3b6ee6
--- /dev/null
+++ b/t/recipes/checks/languages/python/files-python-module-has-overly-generic-name/eval/hints
@@ -0,0 +1,9 @@
+python3-foo (binary): python-package-missing-depends-on-python
+python3-foo (binary): python-module-has-overly-generic-name (tests) [usr/lib/python3/dist-packages/tests/__init__.py]
+python3-foo (binary): python-module-has-overly-generic-name (tests) [usr/lib/python3/dist-packages/tests.py]
+python3-foo (binary): python-module-has-overly-generic-name (test) [usr/lib/python3/dist-packages/test/__init__.py]
+python3-foo (binary): python-module-has-overly-generic-name (site) [usr/lib/python3/dist-packages/site.py]
+python3-foo (binary): python-module-has-overly-generic-name (examples) [usr/lib/python3/dist-packages/examples/__init__.py]
+python3-foo (binary): python-module-has-overly-generic-name (example) [usr/lib/python3/dist-packages/example/__init__.py]
+python3-foo (binary): python-module-has-overly-generic-name (docs) [usr/lib/python3/dist-packages/docs/__init__.py]
+python3-foo (binary): python-module-has-overly-generic-name (doc) [usr/lib/python3/dist-packages/doc/__init__.py]