summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/languages/python/python-could-use-pyproject-poetry
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
commit75808db17caf8b960b351e3408e74142f4c85aac (patch)
tree7989e9c09a4240248bf4658a22208a0a52d991c4 /t/recipes/checks/languages/python/python-could-use-pyproject-poetry
parentInitial commit. (diff)
downloadlintian-75808db17caf8b960b351e3408e74142f4c85aac.tar.xz
lintian-75808db17caf8b960b351e3408e74142f4c85aac.zip
Adding upstream version 2.117.0.upstream/2.117.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 't/recipes/checks/languages/python/python-could-use-pyproject-poetry')
-rw-r--r--t/recipes/checks/languages/python/python-could-use-pyproject-poetry/build-spec/debian/control.in18
-rw-r--r--t/recipes/checks/languages/python/python-could-use-pyproject-poetry/build-spec/fill-values3
-rw-r--r--t/recipes/checks/languages/python/python-could-use-pyproject-poetry/build-spec/orig/pyproject.toml17
-rw-r--r--t/recipes/checks/languages/python/python-could-use-pyproject-poetry/eval/desc2
-rw-r--r--t/recipes/checks/languages/python/python-could-use-pyproject-poetry/eval/hints1
5 files changed, 41 insertions, 0 deletions
diff --git a/t/recipes/checks/languages/python/python-could-use-pyproject-poetry/build-spec/debian/control.in b/t/recipes/checks/languages/python/python-could-use-pyproject-poetry/build-spec/debian/control.in
new file mode 100644
index 0000000..18cc016
--- /dev/null
+++ b/t/recipes/checks/languages/python/python-could-use-pyproject-poetry/build-spec/debian/control.in
@@ -0,0 +1,18 @@
+Source: [% $source %]
+Priority: optional
+Section: python
+Maintainer: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %]
+Rules-Requires-Root: no
+
+Package: python3-[% $source %]
+Architecture: all
+Depends: ${misc:Depends}, python3
+Description: Test package (Python 3)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Python 3 variant.
diff --git a/t/recipes/checks/languages/python/python-could-use-pyproject-poetry/build-spec/fill-values b/t/recipes/checks/languages/python/python-could-use-pyproject-poetry/build-spec/fill-values
new file mode 100644
index 0000000..06efd81
--- /dev/null
+++ b/t/recipes/checks/languages/python/python-could-use-pyproject-poetry/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: source-native
+Testname: python-could-use-pyproject-poetry
+Description: Check for a package not built using pyproject poetry, but that could.
diff --git a/t/recipes/checks/languages/python/python-could-use-pyproject-poetry/build-spec/orig/pyproject.toml b/t/recipes/checks/languages/python/python-could-use-pyproject-poetry/build-spec/orig/pyproject.toml
new file mode 100644
index 0000000..cb6ebaa
--- /dev/null
+++ b/t/recipes/checks/languages/python/python-could-use-pyproject-poetry/build-spec/orig/pyproject.toml
@@ -0,0 +1,17 @@
+[build-system]
+requires = ["poetry>=0.12"]
+build-backend = "poetry.core.masonry.api"
+
+[tool.poetry]
+name = "foo"
+description = "an example module"
+version = "0.1"
+authors = ["Stefano Rivera <stefanor@debian.org>"]
+license = "Expat"
+
+[tool.poetry.dependencies]
+tomli = "^1.0.0"
+importlib-metadata = { version="*", python = "<3.5" }
+
+[tool.poetry.scripts]
+foo = 'foo:main'
diff --git a/t/recipes/checks/languages/python/python-could-use-pyproject-poetry/eval/desc b/t/recipes/checks/languages/python/python-could-use-pyproject-poetry/eval/desc
new file mode 100644
index 0000000..c1b69de
--- /dev/null
+++ b/t/recipes/checks/languages/python/python-could-use-pyproject-poetry/eval/desc
@@ -0,0 +1,2 @@
+Testname: python-could-use-pyproject-poetry
+Check: languages/python
diff --git a/t/recipes/checks/languages/python/python-could-use-pyproject-poetry/eval/hints b/t/recipes/checks/languages/python/python-could-use-pyproject-poetry/eval/hints
new file mode 100644
index 0000000..3fd8894
--- /dev/null
+++ b/t/recipes/checks/languages/python/python-could-use-pyproject-poetry/eval/hints
@@ -0,0 +1 @@
+python-could-use-pyproject-poetry (source): missing-prerequisite-for-pyproject-backend poetry.core.masonry.api (does not satisfy python3-poetry-core:any, pybuild-plugin-pyproject:any) [pyproject.toml:3]