summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
commit75808db17caf8b960b351e3408e74142f4c85aac (patch)
tree7989e9c09a4240248bf4658a22208a0a52d991c4 /t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility
parentInitial commit. (diff)
downloadlintian-75808db17caf8b960b351e3408e74142f4c85aac.tar.xz
lintian-75808db17caf8b960b351e3408e74142f4c85aac.zip
Adding upstream version 2.117.0.upstream/2.117.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 't/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility')
-rw-r--r--t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/build-spec/debian/control.in27
-rw-r--r--t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/build-spec/debian/systemd-service-file-uses-deprecated-syslog-facility-bad.service12
-rw-r--r--t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/build-spec/debian/systemd-service-file-uses-deprecated-syslog-facility-good.service12
-rw-r--r--t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/build-spec/fill-values3
-rw-r--r--t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/eval/desc2
-rw-r--r--t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/eval/hints4
6 files changed, 60 insertions, 0 deletions
diff --git a/t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/build-spec/debian/control.in b/t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/build-spec/debian/control.in
new file mode 100644
index 0000000..d42ecbb
--- /dev/null
+++ b/t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/build-spec/debian/control.in
@@ -0,0 +1,27 @@
+Source: [% $source %]
+Priority: optional
+Section: misc
+Maintainer: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %]
+Rules-Requires-Root: no
+
+Package: [% $source %]-good
+Architecture: all
+Depends: ${misc:Depends}
+Description: [% $description %] (good)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ Good case.
+
+Package: [% $source %]-bad
+Architecture: all
+Depends: ${misc:Depends}
+Description: [% $description %] (bad)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+ .
+ Bad case.
diff --git a/t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/build-spec/debian/systemd-service-file-uses-deprecated-syslog-facility-bad.service b/t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/build-spec/debian/systemd-service-file-uses-deprecated-syslog-facility-bad.service
new file mode 100644
index 0000000..748a16a
--- /dev/null
+++ b/t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/build-spec/debian/systemd-service-file-uses-deprecated-syslog-facility-bad.service
@@ -0,0 +1,12 @@
+[Unit]
+After=network.target
+Documentation=https://example.com/
+
+[Service]
+ExecStart=/bin/test
+PIDFile=/run/$NAME.pid
+StandardOutput=syslog
+StandardError=syslog-console
+
+[Install]
+WantedBy=multi-user.target
diff --git a/t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/build-spec/debian/systemd-service-file-uses-deprecated-syslog-facility-good.service b/t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/build-spec/debian/systemd-service-file-uses-deprecated-syslog-facility-good.service
new file mode 100644
index 0000000..30adb06
--- /dev/null
+++ b/t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/build-spec/debian/systemd-service-file-uses-deprecated-syslog-facility-good.service
@@ -0,0 +1,12 @@
+[Unit]
+After=network.target
+Documentation=https://example.com/
+
+[Service]
+ExecStart=/bin/test
+PIDFile=/run/$NAME.pid
+StandardOutput=null
+StandardError=null
+
+[Install]
+WantedBy=multi-user.target
diff --git a/t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/build-spec/fill-values b/t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/build-spec/fill-values
new file mode 100644
index 0000000..5e50e83
--- /dev/null
+++ b/t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: systemd-service-file-uses-deprecated-syslog-facility
+Description: Check for StandardOutput=syslog etc.
diff --git a/t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/eval/desc b/t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/eval/desc
new file mode 100644
index 0000000..dc5a226
--- /dev/null
+++ b/t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/eval/desc
@@ -0,0 +1,2 @@
+Testname: systemd-service-file-uses-deprecated-syslog-facility
+Check: systemd
diff --git a/t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/eval/hints b/t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/eval/hints
new file mode 100644
index 0000000..41b3248
--- /dev/null
+++ b/t/recipes/checks/systemd/systemd-service-file-uses-deprecated-syslog-facility/eval/hints
@@ -0,0 +1,4 @@
+systemd-service-file-uses-deprecated-syslog-facility-good (binary): systemd-service-file-missing-hardening-features [usr/lib/systemd/system/systemd-service-file-uses-deprecated-syslog-facility-good.service]
+systemd-service-file-uses-deprecated-syslog-facility-bad (binary): systemd-service-file-uses-deprecated-syslog-facility StandardOutput=syslog [usr/lib/systemd/system/systemd-service-file-uses-deprecated-syslog-facility-bad.service]
+systemd-service-file-uses-deprecated-syslog-facility-bad (binary): systemd-service-file-uses-deprecated-syslog-facility StandardError=syslog-console [usr/lib/systemd/system/systemd-service-file-uses-deprecated-syslog-facility-bad.service]
+systemd-service-file-uses-deprecated-syslog-facility-bad (binary): systemd-service-file-missing-hardening-features [usr/lib/systemd/system/systemd-service-file-uses-deprecated-syslog-facility-bad.service]