summaryrefslogtreecommitdiffstats
path: root/t/templates/changes-simple-filler
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-14 13:42:30 +0000
commit75808db17caf8b960b351e3408e74142f4c85aac (patch)
tree7989e9c09a4240248bf4658a22208a0a52d991c4 /t/templates/changes-simple-filler
parentInitial commit. (diff)
downloadlintian-75808db17caf8b960b351e3408e74142f4c85aac.tar.xz
lintian-75808db17caf8b960b351e3408e74142f4c85aac.zip
Adding upstream version 2.117.0.upstream/2.117.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 't/templates/changes-simple-filler')
-rw-r--r--t/templates/changes-simple-filler/Makefile.in17
-rw-r--r--t/templates/changes-simple-filler/fill-values.d/changes-simple-filler.values2
2 files changed, 19 insertions, 0 deletions
diff --git a/t/templates/changes-simple-filler/Makefile.in b/t/templates/changes-simple-filler/Makefile.in
new file mode 100644
index 0000000..286cc6d
--- /dev/null
+++ b/t/templates/changes-simple-filler/Makefile.in
@@ -0,0 +1,17 @@
+ROOT_DIR:=$(shell dirname $(realpath $(lastword $(MAKEFILE_LIST))))
+
+product = [% $build_product %]
+
+references = $(ROOT_DIR)/referenced-files
+
+.DEFAULT_GOAL := $(product)
+
+$(product): $(ROOT_DIR)/$(product)
+ if [ -d $(references) ] ; then \
+ cp -rp $(references)/. . ; \
+ fi
+ cp $(ROOT_DIR)/$(product) $(product)
+
+.PHONY: clean
+clean:
+ rm -f $(product)
diff --git a/t/templates/changes-simple-filler/fill-values.d/changes-simple-filler.values b/t/templates/changes-simple-filler/fill-values.d/changes-simple-filler.values
new file mode 100644
index 0000000..5332dd2
--- /dev/null
+++ b/t/templates/changes-simple-filler/fill-values.d/changes-simple-filler.values
@@ -0,0 +1,2 @@
+Build-Product: test.changes
+Build-Command: make -f [% $source_path %]/Makefile