summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/debhelper/debhelper-dh-exec/build-spec')
-rwxr-xr-xt/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/dirs3
-rwxr-xr-xt/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/install6
-rwxr-xr-xt/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/links2
-rwxr-xr-xt/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/manpages5
-rwxr-xr-xt/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/mime2
-rwxr-xr-xt/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/rules16
-rw-r--r--t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/fill-values4
7 files changed, 38 insertions, 0 deletions
diff --git a/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/dirs b/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/dirs
new file mode 100755
index 0000000..aaac17a
--- /dev/null
+++ b/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/dirs
@@ -0,0 +1,3 @@
+#! /usr/bin/dh-exec
+usr/lib
+usr/lib/${DEB_HOST_MULTIARCH}/octave/packages
diff --git a/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/install b/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/install
new file mode 100755
index 0000000..c79e8ae
--- /dev/null
+++ b/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/install
@@ -0,0 +1,6 @@
+#! /usr/bin/dh-exec
+usr/lib/foo [linux-any] [hurd-any] [kfreebsd-any]
+usr/lib/${DEB_HOST_MULTIARCH}
+usr/lib/${DEB_HOST_MULTIARCH} /usr/lib/${DEB_HOST_MULTIARCH}/
+usr/lib/${DEB_BUILD_MULTIARCH} /usr/lib/${DEB_HOST_MULTIARCH}/
+usr/lib/${DEB_HOST_MULTIARCH}/some-package/*.so
diff --git a/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/links b/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/links
new file mode 100755
index 0000000..3c907d7
--- /dev/null
+++ b/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/links
@@ -0,0 +1,2 @@
+#! /usr/bin/dh-exec
+link-foo => link-bar
diff --git a/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/manpages b/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/manpages
new file mode 100755
index 0000000..2209766
--- /dev/null
+++ b/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/manpages
@@ -0,0 +1,5 @@
+#! /usr/lib/dh-exec/dh-exec-subst
+## The above works, but is not recommended.
+foo => bar
+this-line-uses-tabs => this-line-uses-tabs
+${DEB_BUILD_WHATEVER}
diff --git a/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/mime b/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/mime
new file mode 100755
index 0000000..ce8e762
--- /dev/null
+++ b/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/mime
@@ -0,0 +1,2 @@
+#! /usr/bin/dh-exec
+debian/rules
diff --git a/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/rules b/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/rules
new file mode 100755
index 0000000..06b98ae
--- /dev/null
+++ b/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/debian/rules
@@ -0,0 +1,16 @@
+#!/usr/bin/make -f
+
+%:
+ dh $@
+
+# Ignore the "mime" file as we do not really depend on dh-exec and we
+# do not really need the files listed there for the test.
+override_dh_installmime:
+
+
+override_dh_installman:
+
+override_dh_install:
+
+override_dh_installdirs:
+override_dh_link:
diff --git a/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/fill-values b/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/fill-values
new file mode 100644
index 0000000..f359531
--- /dev/null
+++ b/t/recipes/checks/debhelper/debhelper-dh-exec/build-spec/fill-values
@@ -0,0 +1,4 @@
+Skeleton: upload-native
+Testname: debhelper-dh-exec
+Dh-Compat-Level: 9
+Description: Tests related to executable, dh-exec using packaging files