summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debian/changelog/changelog-file-upstream-html-only/build-spec
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/debian/changelog/changelog-file-upstream-html-only/build-spec')
-rw-r--r--t/recipes/checks/debian/changelog/changelog-file-upstream-html-only/build-spec/debian/rules11
-rw-r--r--t/recipes/checks/debian/changelog/changelog-file-upstream-html-only/build-spec/fill-values3
-rw-r--r--t/recipes/checks/debian/changelog/changelog-file-upstream-html-only/build-spec/orig/some-changelog.html8
3 files changed, 22 insertions, 0 deletions
diff --git a/t/recipes/checks/debian/changelog/changelog-file-upstream-html-only/build-spec/debian/rules b/t/recipes/checks/debian/changelog/changelog-file-upstream-html-only/build-spec/debian/rules
new file mode 100644
index 0000000..12f2c85
--- /dev/null
+++ b/t/recipes/checks/debian/changelog/changelog-file-upstream-html-only/build-spec/debian/rules
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+
+PKG:=$(shell dh_listpackages)
+DOC:=debian/$(PKG)/usr/share/doc/$(PKG)
+
+%:
+ dh $@
+
+override_dh_installchangelogs:
+ dh_installchangelogs
+ cp some-changelog.html $(DOC)/changelog.html
diff --git a/t/recipes/checks/debian/changelog/changelog-file-upstream-html-only/build-spec/fill-values b/t/recipes/checks/debian/changelog/changelog-file-upstream-html-only/build-spec/fill-values
new file mode 100644
index 0000000..684e84e
--- /dev/null
+++ b/t/recipes/checks/debian/changelog/changelog-file-upstream-html-only/build-spec/fill-values
@@ -0,0 +1,3 @@
+Testname: changelog-file-upstream-html-only
+Skeleton: upload-non-native
+Description: Check HTML-only upstream changelog
diff --git a/t/recipes/checks/debian/changelog/changelog-file-upstream-html-only/build-spec/orig/some-changelog.html b/t/recipes/checks/debian/changelog/changelog-file-upstream-html-only/build-spec/orig/some-changelog.html
new file mode 100644
index 0000000..2a4614a
--- /dev/null
+++ b/t/recipes/checks/debian/changelog/changelog-file-upstream-html-only/build-spec/orig/some-changelog.html
@@ -0,0 +1,8 @@
+<html>
+ <head>
+ <titl>Hallo World</title>
+</head>
+<body>
+ <p>A wonderful changelog written in HTML</p>
+</body>
+</html>