summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/debian/debconf/debconf-config-not-executable
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/debian/debconf/debconf-config-not-executable')
-rw-r--r--t/recipes/checks/debian/debconf/debconf-config-not-executable/build-spec/debian/config5
-rw-r--r--t/recipes/checks/debian/debconf/debconf-config-not-executable/build-spec/debian/control.in15
-rwxr-xr-xt/recipes/checks/debian/debconf/debconf-config-not-executable/build-spec/debian/rules10
-rw-r--r--t/recipes/checks/debian/debconf/debconf-config-not-executable/build-spec/fill-values5
-rw-r--r--t/recipes/checks/debian/debconf/debconf-config-not-executable/eval/desc3
-rw-r--r--t/recipes/checks/debian/debconf/debconf-config-not-executable/eval/hints4
6 files changed, 42 insertions, 0 deletions
diff --git a/t/recipes/checks/debian/debconf/debconf-config-not-executable/build-spec/debian/config b/t/recipes/checks/debian/debconf/debconf-config-not-executable/build-spec/debian/config
new file mode 100644
index 0000000..d429f9b
--- /dev/null
+++ b/t/recipes/checks/debian/debconf/debconf-config-not-executable/build-spec/debian/config
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+set -e
+
+. /usr/share/debconf/confmodule
diff --git a/t/recipes/checks/debian/debconf/debconf-config-not-executable/build-spec/debian/control.in b/t/recipes/checks/debian/debconf/debconf-config-not-executable/build-spec/debian/control.in
new file mode 100644
index 0000000..68a964d
--- /dev/null
+++ b/t/recipes/checks/debian/debconf/debconf-config-not-executable/build-spec/debian/control.in
@@ -0,0 +1,15 @@
+Source: [% $source %]
+Priority: optional
+Section: [% $section %]
+Maintainer: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %]
+
+Package: [% $source %]
+Architecture: [% $package_architecture %]
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: [% $description %]
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
diff --git a/t/recipes/checks/debian/debconf/debconf-config-not-executable/build-spec/debian/rules b/t/recipes/checks/debian/debconf/debconf-config-not-executable/build-spec/debian/rules
new file mode 100755
index 0000000..558750b
--- /dev/null
+++ b/t/recipes/checks/debian/debconf/debconf-config-not-executable/build-spec/debian/rules
@@ -0,0 +1,10 @@
+#!/usr/bin/make -f
+
+TMP=debian/$(shell dh_listpackages)
+
+%:
+ dh $@
+
+override_dh_builddeb:
+ chmod 0644 "$(TMP)/DEBIAN/config"
+ dh_builddeb
diff --git a/t/recipes/checks/debian/debconf/debconf-config-not-executable/build-spec/fill-values b/t/recipes/checks/debian/debconf/debconf-config-not-executable/build-spec/fill-values
new file mode 100644
index 0000000..3ea2f84
--- /dev/null
+++ b/t/recipes/checks/debian/debconf/debconf-config-not-executable/build-spec/fill-values
@@ -0,0 +1,5 @@
+Skeleton: upload-native
+Testname: debconf-config-not-executable
+Description: Test for debian/config not being executable
+Extra-Build-Depends: dpkg (<< 1.19.0)
+# dpkg 1.19.0 will error out due to https://anonscm.debian.org/git/dpkg/dpkg.git/commit/?id=cd791ccf8117398ea765eda3a92db52a9cf04c23
diff --git a/t/recipes/checks/debian/debconf/debconf-config-not-executable/eval/desc b/t/recipes/checks/debian/debconf/debconf-config-not-executable/eval/desc
new file mode 100644
index 0000000..be30442
--- /dev/null
+++ b/t/recipes/checks/debian/debconf/debconf-config-not-executable/eval/desc
@@ -0,0 +1,3 @@
+Testname: debconf-config-not-executable
+Check: debian/debconf
+# dpkg 1.19.0 will error out due to https://anonscm.debian.org/git/dpkg/dpkg.git/commit/?id=cd791ccf8117398ea765eda3a92db52a9cf04c23
diff --git a/t/recipes/checks/debian/debconf/debconf-config-not-executable/eval/hints b/t/recipes/checks/debian/debconf/debconf-config-not-executable/eval/hints
new file mode 100644
index 0000000..e5b6aaa
--- /dev/null
+++ b/t/recipes/checks/debian/debconf/debconf-config-not-executable/eval/hints
@@ -0,0 +1,4 @@
+debconf-config-not-executable (binary): postinst-does-not-load-confmodule
+debconf-config-not-executable (binary): no-debconf-templates
+debconf-config-not-executable (binary): debconf-config-not-executable
+debconf-config-not-executable (binary): control-file-has-bad-permissions config 0644 != 0755