summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/desktop/icons/files-general/build-spec/debian
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/desktop/icons/files-general/build-spec/debian')
-rw-r--r--t/recipes/checks/desktop/icons/files-general/build-spec/debian/clean1
-rw-r--r--t/recipes/checks/desktop/icons/files-general/build-spec/debian/dirs13
-rw-r--r--t/recipes/checks/desktop/icons/files-general/build-spec/debian/examples1
-rw-r--r--t/recipes/checks/desktop/icons/files-general/build-spec/debian/install18
-rw-r--r--t/recipes/checks/desktop/icons/files-general/build-spec/debian/links1
-rw-r--r--t/recipes/checks/desktop/icons/files-general/build-spec/debian/manpages2
-rwxr-xr-xt/recipes/checks/desktop/icons/files-general/build-spec/debian/rules67
7 files changed, 103 insertions, 0 deletions
diff --git a/t/recipes/checks/desktop/icons/files-general/build-spec/debian/clean b/t/recipes/checks/desktop/icons/files-general/build-spec/debian/clean
new file mode 100644
index 0000000..222b726
--- /dev/null
+++ b/t/recipes/checks/desktop/icons/files-general/build-spec/debian/clean
@@ -0,0 +1 @@
+鳥の詩.1
diff --git a/t/recipes/checks/desktop/icons/files-general/build-spec/debian/dirs b/t/recipes/checks/desktop/icons/files-general/build-spec/debian/dirs
new file mode 100644
index 0000000..b76fb64
--- /dev/null
+++ b/t/recipes/checks/desktop/icons/files-general/build-spec/debian/dirs
@@ -0,0 +1,13 @@
+etc
+etc/skel
+usr/bin
+usr/doc
+usr/lib/python3/dist-packages/foo
+usr/share/foo
+usr/share/fonts/X11/misc
+usr/share/glib-2.0/schemas
+usr/share/hal
+usr/share/man/man1/random
+var/catman
+var/lock/lintian
+var/run/lintian
diff --git a/t/recipes/checks/desktop/icons/files-general/build-spec/debian/examples b/t/recipes/checks/desktop/icons/files-general/build-spec/debian/examples
new file mode 100644
index 0000000..18fb10f
--- /dev/null
+++ b/t/recipes/checks/desktop/icons/files-general/build-spec/debian/examples
@@ -0,0 +1 @@
+foo.vcproj
diff --git a/t/recipes/checks/desktop/icons/files-general/build-spec/debian/install b/t/recipes/checks/desktop/icons/files-general/build-spec/debian/install
new file mode 100644
index 0000000..dccb61e
--- /dev/null
+++ b/t/recipes/checks/desktop/icons/files-general/build-spec/debian/install
@@ -0,0 +1,18 @@
+lintian-16x16.png usr/share/apps/lintian/icons/hicolor/22x22
+lintian-16x16.png usr/share/icons/hicolor/22x22/apps
+lintian-22x22.png usr/share/apps/lintian/icons/hicolor/22x22
+lintian-22x22.png usr/share/apps/lintian/icons/hicolor/20x20
+lintian-16x16.png usr/share/doc/lintian/
+lintian-22x22.png usr/share/games/icons/hicolor/22x22
+lintian-16x16.png usr/share/icons/hicolor/scalable/apps
+lintian-22x22.png usr/share/icons/16x16/animations/
+--lzma etc/modprobe.d
+lintian.conf etc/modprobe.d
+dir usr/share/info
+foo.vcproj usr/lib/foo
+lintian-lib.conf etc/ld.so.conf.d
+php-foo.ini etc/php/7.0/mods-available
+types usr/share/mime
+mimeinfo.cache usr/share/applications
+file-in-new-top-level-dir new-top-level-dir/
+sudotest etc/sudoers.d/
diff --git a/t/recipes/checks/desktop/icons/files-general/build-spec/debian/links b/t/recipes/checks/desktop/icons/files-general/build-spec/debian/links
new file mode 100644
index 0000000..f3e425d
--- /dev/null
+++ b/t/recipes/checks/desktop/icons/files-general/build-spec/debian/links
@@ -0,0 +1 @@
+usr/share/apps/lintian/icons/hicolor/22x22/lintian-22x22.png usr/share/apps/lintian/icons/hicolor/64x64/lintian-64x64.png
diff --git a/t/recipes/checks/desktop/icons/files-general/build-spec/debian/manpages b/t/recipes/checks/desktop/icons/files-general/build-spec/debian/manpages
new file mode 100644
index 0000000..e8af11b
--- /dev/null
+++ b/t/recipes/checks/desktop/icons/files-general/build-spec/debian/manpages
@@ -0,0 +1,2 @@
+foo.5
+鳥の詩.1
diff --git a/t/recipes/checks/desktop/icons/files-general/build-spec/debian/rules b/t/recipes/checks/desktop/icons/files-general/build-spec/debian/rules
new file mode 100755
index 0000000..798f01e
--- /dev/null
+++ b/t/recipes/checks/desktop/icons/files-general/build-spec/debian/rules
@@ -0,0 +1,67 @@
+#!/usr/bin/make -f
+
+tmp := $(CURDIR)/debian/$(shell dh_listpackages)
+
+%:
+ dh $@
+
+override_dh_install:
+ dh_install
+ echo "#fake conf file" > $(tmp)/etc/pam.conf
+ # true positives
+ touch $(tmp)/etc/skel/.lintianrc
+ # false positives
+ touch $(tmp)/etc/skel/.bashrc
+ touch $(tmp)/etc/skel/.bash_logout
+ touch $(tmp)/etc/skel/.profile
+ touch $(tmp)/etc/skel/.kshrc
+ touch $(tmp)/etc/skel/.mkshrc
+ echo "Back-up file" > $(tmp)/usr/share/foo/file~
+ # The name of the "binary" is "Tori no Uta"
+ # If it is ever messed up, it can be restored by
+ # using something like:
+ # perl -pe 's/\@FILE\@/\xe9\xb3\xa5\xe3\x81\xae\xe8\xa9\xa9\x0a/'
+ echo "#!/bin/sh" > $(tmp)/usr/bin/鳥の詩
+ chmod +x $(tmp)/usr/bin/鳥の詩
+ # Copy the manpage to its correct name so dh_installman can
+ # find it.
+ # - d/clean will remove it again
+ cp -a tnu.1 鳥の詩.1
+ touch $(tmp)/usr/doc/FSSTND
+ touch $(tmp)/usr/share/foo/'*'
+ touch $(tmp)/usr/share/foo/'ws '
+ touch $(tmp)/usr/share/fonts/X11/misc/fonts.dir
+ touch $(tmp)/usr/share/fonts/X11/misc/fonts.scale
+ touch $(tmp)/usr/share/fonts/X11/misc/fonts.alias
+ touch $(tmp)/usr/share/fonts/X11/misc/encodings.dir
+ touch $(tmp)/usr/share/fonts/X11/misc/false-positive
+ touch $(tmp)/usr/share/foo/.nfs-fake-tmpfile
+ touch $(tmp)/usr/share/foo/foo.doctree
+ touch $(tmp)/usr/share/foo/gschemas.compiled
+ touch $(tmp)/usr/share/glib-2.0/schemas/gschemas.compiled
+ touch $(tmp)/usr/share/hal/foo.fdi
+ touch $(tmp)/usr/lib/python3/dist-packages/test_foo.py
+ touch $(tmp)/usr/lib/python3/dist-packages/foo/test_falsepositive.py
+ # If the following line gets messed up, it can be
+ # restored with something like:
+ # sed -i 's/@FILE@/bokm\xe5l/'
+ touch $(tmp)/usr/share/foo/bokml
+ touch $(tmp)/var/catman/do
+
+override_dh_fixperms:
+ dh_fixperms
+ chmod 755 $(tmp)/usr/share/man/man5/foo.5.gz
+ chmod 644 $(tmp)/etc/sudoers.d/*
+
+override_dh_compress:
+ dh_compress
+ # create a .png and .png.gz
+ gzip -n -1 $(tmp)/usr/share/doc/lintian/lintian-16x16.png
+ zcat $(tmp)/usr/share/doc/lintian/lintian-16x16.png.gz > \
+ $(tmp)/usr/share/doc/lintian/lintian-16x16.png
+
+override_dh_link:
+ dh_link
+ mkdir -p $(tmp)/usr/share/doc/bar
+ echo "Hallo World" > $(tmp)/usr/share/doc/bar/foo
+ ln -s ../bar/foo $(tmp)/usr/share/doc/bar/star