summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/documentation/files-zero-byte-doc
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/documentation/files-zero-byte-doc')
-rw-r--r--t/recipes/checks/documentation/files-zero-byte-doc/build-spec/fill-values4
-rw-r--r--t/recipes/checks/documentation/files-zero-byte-doc/build-spec/orig/Makefile29
-rw-r--r--t/recipes/checks/documentation/files-zero-byte-doc/eval/desc3
-rw-r--r--t/recipes/checks/documentation/files-zero-byte-doc/eval/hints6
-rw-r--r--t/recipes/checks/documentation/files-zero-byte-doc/eval/post-test2
5 files changed, 44 insertions, 0 deletions
diff --git a/t/recipes/checks/documentation/files-zero-byte-doc/build-spec/fill-values b/t/recipes/checks/documentation/files-zero-byte-doc/build-spec/fill-values
new file mode 100644
index 0000000..2f4ccc2
--- /dev/null
+++ b/t/recipes/checks/documentation/files-zero-byte-doc/build-spec/fill-values
@@ -0,0 +1,4 @@
+Skeleton: upload-native
+Testname: files-zero-byte-doc
+Section: doc
+Description: Check detection of zero-byte files in doc directories
diff --git a/t/recipes/checks/documentation/files-zero-byte-doc/build-spec/orig/Makefile b/t/recipes/checks/documentation/files-zero-byte-doc/build-spec/orig/Makefile
new file mode 100644
index 0000000..3f77ca4
--- /dev/null
+++ b/t/recipes/checks/documentation/files-zero-byte-doc/build-spec/orig/Makefile
@@ -0,0 +1,29 @@
+ROOT = $(DESTDIR)/usr/share/doc/files-zero-byte-doc
+
+default:
+ :
+
+install:
+ mkdir -p $(ROOT)
+ # Should be ignored.
+ mkdir -p $(ROOT)/examples
+ touch $(ROOT)/examples/empty
+ touch $(ROOT)/__init__.py
+ mkdir -p $(ROOT)/python/foo
+ touch $(ROOT)/python/foo/__init__.py
+ mkdir -p $(ROOT)/html
+ touch $(ROOT)/html/blah.map
+ mkdir -p $(ROOT)/manual/1/html/foo
+ touch $(ROOT)/manual/1/html/foo/blah.map
+ # Should be diagnosed.
+ touch $(ROOT)/NEWS
+ touch $(ROOT)/foo__init__.py
+ touch $(ROOT)/html.map
+ touch $(ROOT)/htmlfoo.map
+ mkdir -p $(ROOT)/manual
+ touch $(ROOT)/manual/foo.map
+ gzip -n -9 $(ROOT)/manual/foo.map
+ touch $(ROOT)/some-really-long-file-name-to-make-the-gzip-file-larger
+ gzip -n -9 $(ROOT)/some-really-long-file-name-to-make-the-gzip-file-larger
+
+.PHONY: clean distclean realclean install check test
diff --git a/t/recipes/checks/documentation/files-zero-byte-doc/eval/desc b/t/recipes/checks/documentation/files-zero-byte-doc/eval/desc
new file mode 100644
index 0000000..3918c23
--- /dev/null
+++ b/t/recipes/checks/documentation/files-zero-byte-doc/eval/desc
@@ -0,0 +1,3 @@
+Testname: files-zero-byte-doc
+See-Also: Debian Bug#507273
+Check: documentation
diff --git a/t/recipes/checks/documentation/files-zero-byte-doc/eval/hints b/t/recipes/checks/documentation/files-zero-byte-doc/eval/hints
new file mode 100644
index 0000000..79717d5
--- /dev/null
+++ b/t/recipes/checks/documentation/files-zero-byte-doc/eval/hints
@@ -0,0 +1,6 @@
+files-zero-byte-doc (binary): zero-byte-file-in-doc-directory [usr/share/doc/files-zero-byte-doc/some-really-long-file-name-to-make-the-gzip-file-larger.gz]
+files-zero-byte-doc (binary): zero-byte-file-in-doc-directory [usr/share/doc/files-zero-byte-doc/manual/foo.map.gz]
+files-zero-byte-doc (binary): zero-byte-file-in-doc-directory [usr/share/doc/files-zero-byte-doc/htmlfoo.map]
+files-zero-byte-doc (binary): zero-byte-file-in-doc-directory [usr/share/doc/files-zero-byte-doc/html.map]
+files-zero-byte-doc (binary): zero-byte-file-in-doc-directory [usr/share/doc/files-zero-byte-doc/foo__init__.py]
+files-zero-byte-doc (binary): zero-byte-file-in-doc-directory [usr/share/doc/files-zero-byte-doc/NEWS.gz]
diff --git a/t/recipes/checks/documentation/files-zero-byte-doc/eval/post-test b/t/recipes/checks/documentation/files-zero-byte-doc/eval/post-test
new file mode 100644
index 0000000..8538b49
--- /dev/null
+++ b/t/recipes/checks/documentation/files-zero-byte-doc/eval/post-test
@@ -0,0 +1,2 @@
+# Ignore all duplicate-files tags
+/.: .*: duplicate-files .*/ d