summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/files/hard-links/legacy-etcfiles
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/files/hard-links/legacy-etcfiles')
-rw-r--r--t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/README.Debian5
-rw-r--r--t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/changelog.in7
-rw-r--r--t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/conffiles5
-rw-r--r--t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/conffiles.only2
-rw-r--r--t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/control20
-rwxr-xr-xt/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/rules64
-rw-r--r--t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/fill-values5
-rw-r--r--t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/orig/improper2
-rw-r--r--t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/orig/proper2
-rw-r--r--t/recipes/checks/files/hard-links/legacy-etcfiles/eval/desc2
-rw-r--r--t/recipes/checks/files/hard-links/legacy-etcfiles/eval/hints1
-rw-r--r--t/recipes/checks/files/hard-links/legacy-etcfiles/eval/post-test1
12 files changed, 116 insertions, 0 deletions
diff --git a/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/README.Debian b/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/README.Debian
new file mode 100644
index 0000000..e289bfb
--- /dev/null
+++ b/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/README.Debian
@@ -0,0 +1,5 @@
+this is a package to test lintian's handling of files in /etc.
+Also, there's a random mention of /usr/doc here to prompt a warning.
+But /usr/documentation doesn't.
+
+ -- Russ Allbery <rra@debian.org>, Mon, 18 Feb 2008 16:40:55 -0800
diff --git a/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/changelog.in b/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/changelog.in
new file mode 100644
index 0000000..00cdc77
--- /dev/null
+++ b/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/changelog.in
@@ -0,0 +1,7 @@
+etcfiles ([% $version %]) [% $distribution %]; urgency=low
+
+ * Acknowledge NMU (Closes: #123456).
+ * initial setup
+
+ -- Lintian Maintainers <lintian-maint@debian.org> Fri, 21 Sep 2001 11:56:02 -0700
+
diff --git a/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/conffiles b/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/conffiles
new file mode 100644
index 0000000..76032b7
--- /dev/null
+++ b/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/conffiles
@@ -0,0 +1,5 @@
+/etc/proper
+/var/lib/foo
+/etc/cron.daily/cronfile-normal
+/etc/cron.daily/.cronfile-begins-with-fullstop
+/etc/cron.daily/cronfile-contains.fullstop
diff --git a/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/conffiles.only b/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/conffiles.only
new file mode 100644
index 0000000..a4b3895
--- /dev/null
+++ b/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/conffiles.only
@@ -0,0 +1,2 @@
+/etc/etcfiles/foo
+/etc/etcfiles/bar
diff --git a/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/control b/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/control
new file mode 100644
index 0000000..f3dbda7
--- /dev/null
+++ b/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/control
@@ -0,0 +1,20 @@
+Source: etcfiles
+Section: misc
+Priority: optional
+Maintainer: Lintian Maintainers <lintian-maint@debian.org>
+Standards-Version: 3.5.0
+
+Package: etcfiles
+Architecture: any
+Depends: ${shlibs:Depends}
+Description: test handling of files in /etc
+ Regression test for lintian's handling of files in /etc.
+ .
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package.
+
+Package: only-etcfiles
+Architecture: all
+Depends: etcfiles (= ${source:Version})
+Description: test handling of conffile-only package
diff --git a/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/rules b/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/rules
new file mode 100755
index 0000000..97ff09f
--- /dev/null
+++ b/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/debian/rules
@@ -0,0 +1,64 @@
+#!/usr/bin/make -f
+
+tmp=debian/tmp
+tmponly=debian/only-etcfiles
+
+clean:
+ rm -f debian/files debian/substvars
+ rm -rf debian/tmp
+ rm -rf debian/only-etcfiles
+
+build:
+build-arch:
+build-indep:
+binary-indep:
+ install -d $(tmp)/etc
+ install -m 644 proper $(tmp)/etc
+ install -m 644 improper $(tmp)/etc
+ mkdir $(tmp)/etc/cron.daily
+ touch $(tmp)/etc/cron.daily/cronfile-normal
+ touch $(tmp)/etc/cron.daily/.cronfile-begins-with-fullstop
+ touch $(tmp)/etc/cron.daily/cronfile-contains.fullstop
+ ln $(tmp)/etc/improper $(tmp)/etc/improper-link
+ install -d $(tmp)/usr/share/doc/etcfiles
+ install -d $(tmp)/var/lib
+ install -m 644 proper $(tmp)/var/lib/foo
+ install -m 644 debian/README.Debian $(tmp)/usr/share/doc/etcfiles
+ install -m 644 debian/changelog $(tmp)/usr/share/doc/etcfiles
+ #gzip -9 $(tmp)/usr/share/doc/etcfiles/changelog
+ install -d $(tmp)/DEBIAN
+ install -m 644 debian/conffiles $(tmp)/DEBIAN
+
+ echo 'd41d8cd98f00b204e9800998ecf8427e ./etc/cron.daily/cronfile-normal' \
+ > debian/tmp/DEBIAN/md5sums
+ echo 'd41d8cd98f00b204e9800998ecf8427e ./etc/cron.daily/.cronfile-begins-with-fullstop' \
+ >> debian/tmp/DEBIAN/md5sums
+ echo 'd41d8cd98f00b204e9800998ecf8427e ./etc/cron.daily/cronfile-contains.fullstop' \
+ >> debian/tmp/DEBIAN/md5sums
+ echo '05c72cacce994208128b7d081116b04a ./etc/proper' \
+ >> debian/tmp/DEBIAN/md5sums
+ echo 'ab371382468880299e5ebd05921764ce etc/improper' \
+ >> debian/tmp/DEBIAN/md5sums
+ echo 'ab371382468880299e5ebd05921764ce usr/bin/foo' \
+ >> debian/tmp/DEBIAN/md5sums
+ echo 'this is a malformed line' \
+ >> debian/tmp/DEBIAN/md5sums
+ echo '56fb27e455dd86d8801f1ecd3a4cee49 usr/share/doc/etcfiles/README.Debian' \
+ >> debian/tmp/DEBIAN/md5sums
+
+ install -d $(tmponly)/etc/etcfiles
+ touch $(tmponly)/etc/etcfiles/foo
+ touch $(tmponly)/etc/etcfiles/bar
+ install -d $(tmponly)/usr/share/doc
+ cd $(tmponly)/usr/share/doc && ln -s etcfiles only-etcfiles
+ install -d $(tmponly)/DEBIAN
+ install -m 644 debian/conffiles.only $(tmponly)/DEBIAN/conffiles
+
+ dpkg-gencontrol -isp -petcfiles
+ dpkg-gencontrol -isp -ponly-etcfiles -P$(tmponly)
+ dpkg --build $(tmp) ..
+ dpkg --build $(tmponly) ..
+
+binary: binary-indep
+
+.PHONY: binary-indep binary clean
diff --git a/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/fill-values b/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/fill-values
new file mode 100644
index 0000000..86deb10
--- /dev/null
+++ b/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/fill-values
@@ -0,0 +1,5 @@
+Skeleton: upload-native
+Testname: legacy-etcfiles
+Source: etcfiles
+Version: 1
+Description: Legacy test "etcfiles"
diff --git a/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/orig/improper b/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/orig/improper
new file mode 100644
index 0000000..23656f4
--- /dev/null
+++ b/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/orig/improper
@@ -0,0 +1,2 @@
+[config]
+ var = value \ No newline at end of file
diff --git a/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/orig/proper b/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/orig/proper
new file mode 100644
index 0000000..f3dc68b
--- /dev/null
+++ b/t/recipes/checks/files/hard-links/legacy-etcfiles/build-spec/orig/proper
@@ -0,0 +1,2 @@
+# i am a config file
+foo = var \ No newline at end of file
diff --git a/t/recipes/checks/files/hard-links/legacy-etcfiles/eval/desc b/t/recipes/checks/files/hard-links/legacy-etcfiles/eval/desc
new file mode 100644
index 0000000..dd9045e
--- /dev/null
+++ b/t/recipes/checks/files/hard-links/legacy-etcfiles/eval/desc
@@ -0,0 +1,2 @@
+Testname: legacy-etcfiles
+Check: files/hard-links
diff --git a/t/recipes/checks/files/hard-links/legacy-etcfiles/eval/hints b/t/recipes/checks/files/hard-links/legacy-etcfiles/eval/hints
new file mode 100644
index 0000000..ff4e25b
--- /dev/null
+++ b/t/recipes/checks/files/hard-links/legacy-etcfiles/eval/hints
@@ -0,0 +1 @@
+etcfiles (binary): package-contains-hardlink pointing to: etc/improper [etc/improper-link]
diff --git a/t/recipes/checks/files/hard-links/legacy-etcfiles/eval/post-test b/t/recipes/checks/files/hard-links/legacy-etcfiles/eval/post-test
new file mode 100644
index 0000000..faeef0b
--- /dev/null
+++ b/t/recipes/checks/files/hard-links/legacy-etcfiles/eval/post-test
@@ -0,0 +1 @@
+s/\(current is ([0-9]+\.)+[0-9]\)/(current is CURRENT)/