summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/languages/python/python-django-package-does-not-depend-on-django
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/languages/python/python-django-package-does-not-depend-on-django')
-rw-r--r--t/recipes/checks/languages/python/python-django-package-does-not-depend-on-django/build-spec/debian/control.in61
-rw-r--r--t/recipes/checks/languages/python/python-django-package-does-not-depend-on-django/build-spec/fill-values3
-rw-r--r--t/recipes/checks/languages/python/python-django-package-does-not-depend-on-django/eval/desc2
-rw-r--r--t/recipes/checks/languages/python/python-django-package-does-not-depend-on-django/eval/hints3
4 files changed, 69 insertions, 0 deletions
diff --git a/t/recipes/checks/languages/python/python-django-package-does-not-depend-on-django/build-spec/debian/control.in b/t/recipes/checks/languages/python/python-django-package-does-not-depend-on-django/build-spec/debian/control.in
new file mode 100644
index 0000000..81556b8
--- /dev/null
+++ b/t/recipes/checks/languages/python/python-django-package-does-not-depend-on-django/build-spec/debian/control.in
@@ -0,0 +1,61 @@
+Source: [% $source %]
+Priority: optional
+Section: python
+Maintainer: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %]
+Rules-Requires-Root: no
+
+Package: python-django-positive
+Architecture: all
+Depends: ${misc:Depends}, python2.7
+Description: Python 2 package without corresponding python-django dependency
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+
+Package: python2-django-positive
+Architecture: all
+Depends: ${misc:Depends}, python2.7
+Description: Python 2 package without corresponding python-django dependency (explicit)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Explicit Python 2 variant.
+
+Package: python3-django-positive
+Architecture: all
+Depends: ${misc:Depends}, python3
+Description: Python 3 package without corresponding python3-django dependency
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Python 3 variant.
+
+Package: python-django-false-positive
+Architecture: all
+Depends: ${misc:Depends}, python2.7, python-django
+Description: Python 2 package with corresponding python3-django dependency
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ This is a false positive.
+
+Package: python3-django-false-positive
+Architecture: all
+Pre-Depends: python3-django
+Depends: ${misc:Depends}, python3
+Description: Python 3 package with corresponding python3-django dependency
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Python 3 variant of the false positive.
diff --git a/t/recipes/checks/languages/python/python-django-package-does-not-depend-on-django/build-spec/fill-values b/t/recipes/checks/languages/python/python-django-package-does-not-depend-on-django/build-spec/fill-values
new file mode 100644
index 0000000..3c28985
--- /dev/null
+++ b/t/recipes/checks/languages/python/python-django-package-does-not-depend-on-django/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: python-django-package-does-not-depend-on-django
+Description: Check for Django packages that do not specify a Django Depends
diff --git a/t/recipes/checks/languages/python/python-django-package-does-not-depend-on-django/eval/desc b/t/recipes/checks/languages/python/python-django-package-does-not-depend-on-django/eval/desc
new file mode 100644
index 0000000..09cdb4a
--- /dev/null
+++ b/t/recipes/checks/languages/python/python-django-package-does-not-depend-on-django/eval/desc
@@ -0,0 +1,2 @@
+Testname: python-django-package-does-not-depend-on-django
+Check: languages/python
diff --git a/t/recipes/checks/languages/python/python-django-package-does-not-depend-on-django/eval/hints b/t/recipes/checks/languages/python/python-django-package-does-not-depend-on-django/eval/hints
new file mode 100644
index 0000000..5041e0b
--- /dev/null
+++ b/t/recipes/checks/languages/python/python-django-package-does-not-depend-on-django/eval/hints
@@ -0,0 +1,3 @@
+python3-django-positive (binary): django-package-does-not-depend-on-django python3-django
+python2-django-positive (binary): django-package-does-not-depend-on-django python-django
+python-django-positive (binary): django-package-does-not-depend-on-django python-django