summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/languages/python/python-python2-apps
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/languages/python/python-python2-apps')
-rw-r--r--t/recipes/checks/languages/python/python-python2-apps/build-spec/debian/control.in87
-rw-r--r--t/recipes/checks/languages/python/python-python2-apps/build-spec/fill-values3
-rw-r--r--t/recipes/checks/languages/python/python-python2-apps/eval/desc2
-rw-r--r--t/recipes/checks/languages/python/python-python2-apps/eval/hints6
4 files changed, 98 insertions, 0 deletions
diff --git a/t/recipes/checks/languages/python/python-python2-apps/build-spec/debian/control.in b/t/recipes/checks/languages/python/python-python2-apps/build-spec/debian/control.in
new file mode 100644
index 0000000..9fa4e88
--- /dev/null
+++ b/t/recipes/checks/languages/python/python-python2-apps/build-spec/debian/control.in
@@ -0,0 +1,87 @@
+Source: [% $source %]
+Priority: optional
+Section: python
+Maintainer: [% $author %]
+Build-Depends: [% $build_depends %]
+Standards-Version: [% $standards_version %]
+Rules-Requires-Root: no
+
+Package: pkg-depends
+Architecture: all
+Depends: ${misc:Depends}, python2
+Description: Test package with Python 2.x in Depends
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Description: Test package with Python 2.x in Depends.
+
+Package: pkg-pre-depends
+Architecture: all
+Depends: ${misc:Depends}
+Pre-Depends: python2.7
+Description: Test package with Python 2.x in Pre-Suggests
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Description: Test package with Python 2.x in Pre-Depends.
+
+Package: pkg-recommends
+Architecture: all
+Depends: ${misc:Depends}
+Recommends: python2-dev
+Description: Test package with Python 2.x in Recommends
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Description: Test package with Python 2.x in Recommends.
+
+Package: pkg-suggests
+Architecture: all
+Depends: ${misc:Depends}
+Suggests: python2, python2.7
+Description: Test package with Python 2.x in Suggests
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Description: Test package with Python 2.x in Suggests.
+
+Package: python-[% $source %]
+Architecture: all
+Depends: ${misc:Depends}, python2
+Description: Python 3 module with Python 3.x in Depends
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Python module with Python 2.x in Depends.
+
+Package: python3-[% $source %]
+Architecture: all
+Depends: ${misc:Depends}, python3
+Description: Test package (Python 3)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Python 3 module with Python 3.x in Depends.
+
+Package: pkg-depends-any
+Architecture: all
+Depends: ${misc:Depends}, python2:any
+Description: Test package with Python 2.x with :any suffix in Depends
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ Description: Test package with Python 2.x with :any suffix in Depends.
diff --git a/t/recipes/checks/languages/python/python-python2-apps/build-spec/fill-values b/t/recipes/checks/languages/python/python-python2-apps/build-spec/fill-values
new file mode 100644
index 0000000..eb6243a
--- /dev/null
+++ b/t/recipes/checks/languages/python/python-python2-apps/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: python-python2-apps
+Description: Check packages that Depend/Suggest etc. on Python 2.x
diff --git a/t/recipes/checks/languages/python/python-python2-apps/eval/desc b/t/recipes/checks/languages/python/python-python2-apps/eval/desc
new file mode 100644
index 0000000..0172879
--- /dev/null
+++ b/t/recipes/checks/languages/python/python-python2-apps/eval/desc
@@ -0,0 +1,2 @@
+Testname: python-python2-apps
+Check: languages/python
diff --git a/t/recipes/checks/languages/python/python-python2-apps/eval/hints b/t/recipes/checks/languages/python/python-python2-apps/eval/hints
new file mode 100644
index 0000000..b10f957
--- /dev/null
+++ b/t/recipes/checks/languages/python/python-python2-apps/eval/hints
@@ -0,0 +1,6 @@
+pkg-suggests (binary): dependency-on-python-version-marked-for-end-of-life Suggests (satisfies python2:any)
+pkg-suggests (binary): dependency-on-python-version-marked-for-end-of-life Suggests (satisfies python2.7:any)
+pkg-recommends (binary): dependency-on-python-version-marked-for-end-of-life Recommends (satisfies python2-dev:any)
+pkg-pre-depends (binary): dependency-on-python-version-marked-for-end-of-life Pre-Depends (satisfies python2.7:any)
+pkg-depends-any (binary): dependency-on-python-version-marked-for-end-of-life Depends (satisfies python2:any)
+pkg-depends (binary): dependency-on-python-version-marked-for-end-of-life Depends (satisfies python2:any)