summaryrefslogtreecommitdiffstats
path: root/t/recipes/checks/scripts/scripts-skip-systemd-native
diff options
context:
space:
mode:
Diffstat (limited to 't/recipes/checks/scripts/scripts-skip-systemd-native')
-rw-r--r--t/recipes/checks/scripts/scripts-skip-systemd-native/build-spec/debian/control.in30
-rw-r--r--t/recipes/checks/scripts/scripts-skip-systemd-native/build-spec/debian/scripts-skip-systemd-native-with.postinst10
-rw-r--r--t/recipes/checks/scripts/scripts-skip-systemd-native/build-spec/debian/scripts-skip-systemd-native-without.postinst10
-rw-r--r--t/recipes/checks/scripts/scripts-skip-systemd-native/build-spec/fill-values3
-rw-r--r--t/recipes/checks/scripts/scripts-skip-systemd-native/eval/desc2
-rw-r--r--t/recipes/checks/scripts/scripts-skip-systemd-native/eval/hints2
6 files changed, 57 insertions, 0 deletions
diff --git a/t/recipes/checks/scripts/scripts-skip-systemd-native/build-spec/debian/control.in b/t/recipes/checks/scripts/scripts-skip-systemd-native/build-spec/debian/control.in
new file mode 100644
index 0000000..ecbbc46
--- /dev/null
+++ b/t/recipes/checks/scripts/scripts-skip-systemd-native/build-spec/debian/control.in
@@ -0,0 +1,30 @@
+Source: [% $source %]
+Priority: optional
+Section: [% $section %]
+Maintainer: [% $author %]
+Standards-Version: [% $standards_version %]
+Build-Depends: [% $build_depends %]
+Rules-Requires-Root: no
+
+Package: [% $source %]-with
+Architecture: [% $package_architecture %]
+Depends: ${misc:Depends}
+Pre-Depends: init-system-helpers (>= 1.54~)
+Description: [% $description %] (with)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ This package has the dependency.
+
+Package: [% $source %]-without
+Architecture: [% $package_architecture %]
+Depends: ${misc:Depends}
+Description: [% $description %] (without)
+ This is a test package designed to exercise some feature or tag of
+ Lintian. It is part of the Lintian test suite and may do very odd
+ things. It should not be installed like a regular package. It may
+ be an empty package.
+ .
+ This package is missing the dependency.
diff --git a/t/recipes/checks/scripts/scripts-skip-systemd-native/build-spec/debian/scripts-skip-systemd-native-with.postinst b/t/recipes/checks/scripts/scripts-skip-systemd-native/build-spec/debian/scripts-skip-systemd-native-with.postinst
new file mode 100644
index 0000000..732f9fc
--- /dev/null
+++ b/t/recipes/checks/scripts/scripts-skip-systemd-native/build-spec/debian/scripts-skip-systemd-native-with.postinst
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+set -e
+
+#DEBHELPER#
+
+invoke-rc.d
+invoke-rc.d --skip-systemd-native
+
+exit 0
diff --git a/t/recipes/checks/scripts/scripts-skip-systemd-native/build-spec/debian/scripts-skip-systemd-native-without.postinst b/t/recipes/checks/scripts/scripts-skip-systemd-native/build-spec/debian/scripts-skip-systemd-native-without.postinst
new file mode 100644
index 0000000..732f9fc
--- /dev/null
+++ b/t/recipes/checks/scripts/scripts-skip-systemd-native/build-spec/debian/scripts-skip-systemd-native-without.postinst
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+set -e
+
+#DEBHELPER#
+
+invoke-rc.d
+invoke-rc.d --skip-systemd-native
+
+exit 0
diff --git a/t/recipes/checks/scripts/scripts-skip-systemd-native/build-spec/fill-values b/t/recipes/checks/scripts/scripts-skip-systemd-native/build-spec/fill-values
new file mode 100644
index 0000000..06a0533
--- /dev/null
+++ b/t/recipes/checks/scripts/scripts-skip-systemd-native/build-spec/fill-values
@@ -0,0 +1,3 @@
+Skeleton: upload-native
+Testname: scripts-skip-systemd-native
+Description: Test for packages that use --skip-systemd-native
diff --git a/t/recipes/checks/scripts/scripts-skip-systemd-native/eval/desc b/t/recipes/checks/scripts/scripts-skip-systemd-native/eval/desc
new file mode 100644
index 0000000..2bac3f3
--- /dev/null
+++ b/t/recipes/checks/scripts/scripts-skip-systemd-native/eval/desc
@@ -0,0 +1,2 @@
+Testname: scripts-skip-systemd-native
+Check: scripts
diff --git a/t/recipes/checks/scripts/scripts-skip-systemd-native/eval/hints b/t/recipes/checks/scripts/scripts-skip-systemd-native/eval/hints
new file mode 100644
index 0000000..bc70b78
--- /dev/null
+++ b/t/recipes/checks/scripts/scripts-skip-systemd-native/eval/hints
@@ -0,0 +1,2 @@
+scripts-skip-systemd-native-without (binary): maintainer-script-interpreter /bin/sh [postinst]
+scripts-skip-systemd-native-with (binary): maintainer-script-interpreter /bin/sh [postinst]