summaryrefslogtreecommitdiffstats
path: root/arch/arm/mach-s3c/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:27:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:27:49 +0000
commitace9429bb58fd418f0c81d4c2835699bddf6bde6 (patch)
treeb2d64bc10158fdd5497876388cd68142ca374ed3 /arch/arm/mach-s3c/Makefile
parentInitial commit. (diff)
downloadlinux-ace9429bb58fd418f0c81d4c2835699bddf6bde6.tar.xz
linux-ace9429bb58fd418f0c81d4c2835699bddf6bde6.zip
Adding upstream version 6.6.15.upstream/6.6.15
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'arch/arm/mach-s3c/Makefile')
-rw-r--r--arch/arm/mach-s3c/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/arch/arm/mach-s3c/Makefile b/arch/arm/mach-s3c/Makefile
new file mode 100644
index 0000000000..713827bef8
--- /dev/null
+++ b/arch/arm/mach-s3c/Makefile
@@ -0,0 +1,23 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Copyright 2009 Simtec Electronics
+
+include $(srctree)/$(src)/Makefile.s3c64xx
+
+# Objects we always build independent of SoC choice
+
+obj-y += init.o cpu.o
+
+# devices
+
+obj-$(CONFIG_SAMSUNG_ATAGS) += platformdata.o
+obj-$(CONFIG_SAMSUNG_ATAGS) += devs.o
+obj-$(CONFIG_SAMSUNG_ATAGS) += dev-uart.o
+
+obj-$(CONFIG_GPIO_SAMSUNG) += gpio-samsung.o
+
+# PM support
+
+obj-$(CONFIG_SAMSUNG_PM) += pm.o pm-common.o
+obj-$(CONFIG_SAMSUNG_PM_GPIO) += pm-gpio.o
+obj-$(CONFIG_SAMSUNG_WAKEMASK) += wakeup-mask.o