summaryrefslogtreecommitdiffstats
path: root/arch/riscv/purgatory/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-05 19:27:15 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-05 19:27:15 +0000
commita33528d510dcb2e83b5ff48fb020acd97e9af2db (patch)
tree4838facd92bb3cfae92f01a6dfb780cc47c29d7e /arch/riscv/purgatory/Makefile
parentReleasing progress-linux version 6.9.12-1~progress7.99u1. (diff)
downloadlinux-a33528d510dcb2e83b5ff48fb020acd97e9af2db.tar.xz
linux-a33528d510dcb2e83b5ff48fb020acd97e9af2db.zip
Merging upstream version 6.10.3.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'arch/riscv/purgatory/Makefile')
-rw-r--r--arch/riscv/purgatory/Makefile8
1 files changed, 0 insertions, 8 deletions
diff --git a/arch/riscv/purgatory/Makefile b/arch/riscv/purgatory/Makefile
index 280b0eb352..f11945ee24 100644
--- a/arch/riscv/purgatory/Makefile
+++ b/arch/riscv/purgatory/Makefile
@@ -1,5 +1,4 @@
# SPDX-License-Identifier: GPL-2.0
-OBJECT_FILES_NON_STANDARD := y
purgatory-y := purgatory.o sha256.o entry.o string.o ctype.o memcpy.o memset.o
purgatory-y += strcmp.o strlen.o strncmp.o
@@ -47,13 +46,6 @@ LDFLAGS_purgatory.ro := -r $(PURGATORY_LDFLAGS)
LDFLAGS_purgatory.chk := $(PURGATORY_LDFLAGS)
targets += purgatory.ro purgatory.chk
-# Sanitizer, etc. runtimes are unavailable and cannot be linked here.
-GCOV_PROFILE := n
-KASAN_SANITIZE := n
-UBSAN_SANITIZE := n
-KCSAN_SANITIZE := n
-KCOV_INSTRUMENT := n
-
# These are adjustments to the compiler flags used for objects that
# make up the standalone purgatory.ro