summaryrefslogtreecommitdiffstats
path: root/debian/rules.d
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 17:40:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 17:44:43 +0000
commitb5b67adcc17e3e74dbcda09ff3f8a4636aa53486 (patch)
tree601c346183757b42c53b1d0aa8773cb00d1bd73c /debian/rules.d
parentMerging upstream version 6.7.7. (diff)
downloadlinux-b5b67adcc17e3e74dbcda09ff3f8a4636aa53486.tar.xz
linux-b5b67adcc17e3e74dbcda09ff3f8a4636aa53486.zip
Merging debian version 6.7.7-1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules.d')
-rw-r--r--debian/rules.d/scripts/mod/Makefile.real2
-rw-r--r--debian/rules.d/tools/perf/Makefile8
2 files changed, 7 insertions, 3 deletions
diff --git a/debian/rules.d/scripts/mod/Makefile.real b/debian/rules.d/scripts/mod/Makefile.real
index 6d56ff6ae..40e3ca24e 100644
--- a/debian/rules.d/scripts/mod/Makefile.real
+++ b/debian/rules.d/scripts/mod/Makefile.real
@@ -5,7 +5,7 @@ include $(top_rulesdir)/Makefile.inc
wrapperdir = $(top_rulesdir)/$(OUTDIR)
CFLAGS += -I $(CURDIR)/real-$(TYPE) -I $(wrapperdir)/real-$(TYPE)
-modpost.real-$(TYPE): file2alias.real-$(TYPE).o modpost.real-$(TYPE).o sumversion.real-$(TYPE).o
+modpost.real-$(TYPE): file2alias.real-$(TYPE).o modpost.real-$(TYPE).o sumversion.real-$(TYPE).o symsearch.real-$(TYPE).o
$(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
%.real-$(TYPE).o: $(SOURCEDIR)/%.c real-$(TYPE)/devicetable-offsets.h
diff --git a/debian/rules.d/tools/perf/Makefile b/debian/rules.d/tools/perf/Makefile
index 910f03776..b81116ab1 100644
--- a/debian/rules.d/tools/perf/Makefile
+++ b/debian/rules.d/tools/perf/Makefile
@@ -50,8 +50,12 @@ ifeq (,$(filter nodoc,$(DEB_BUILD_PROFILES)))
+$(MAKE_PERF) -C $(top_srcdir)/tools/perf/Documentation man
endif
# Check that perf didn't get linked against incompatibly-licensed libraries
- type ldd
- ! ldd $(CURDIR)/perf | grep -E '\blib(bfd|crypto|debuginfod)'
+ @if readelf -d $(CURDIR)/perf | sed -rne 's/.*NEEDED.*\[(.*)\]/\1/p' | grep -E '\blib(bfd|crypto|debuginfod)'; then \
+ echo; \
+ echo 'perf linked against incompatibly-licensed libraries'; \
+ echo; \
+ exit 1; \
+ fi
# Check that it links against abi::__cxa_demangle from libstdc++
grep __cxa_demangle $(CURDIR)/perf