summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 17:40:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 17:44:43 +0000
commitb5b67adcc17e3e74dbcda09ff3f8a4636aa53486 (patch)
tree601c346183757b42c53b1d0aa8773cb00d1bd73c /debian/rules
parentMerging upstream version 6.7.7. (diff)
downloadlinux-b5b67adcc17e3e74dbcda09ff3f8a4636aa53486.tar.xz
linux-b5b67adcc17e3e74dbcda09ff3f8a4636aa53486.zip
Merging debian version 6.7.7-1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index b3e901a39e..5d76443b53 100755
--- a/debian/rules
+++ b/debian/rules
@@ -98,7 +98,6 @@ maintainerclean:
# We cannot use dh_clean here because it requires debian/control to exist
rm -rf debian/.debhelper debian/*.debhelper* debian/files debian/generated.*
rm -f \
- debian/config.defines.dump \
debian/control \
debian/control.md5sum \
debian/linux-doc.maintscript \
@@ -123,7 +122,7 @@ clean: debian/control
dh_clean
CONTROL_FILES = $(BUILD_DIR)/version-info $(wildcard debian/templates/*.in)
-CONTROL_FILES += debian/config/defines $(wildcard debian/config/*/defines) $(wildcard debian/config/*/*/defines)
+CONTROL_FILES += debian/config/defines.toml $(wildcard debian/config/*/defines.toml)
CONTROL_FILES += debian/installer/package-list
# debian/bin/gencontrol.py uses debian/changelog as input, but the
@@ -132,7 +131,8 @@ CONTROL_FILES += debian/installer/package-list
# in the checksum.
$(BUILD_DIR)/version-info: debian/changelog
mkdir -p $(@D)
- printf >$@ 'Source: %s\nVersion: %s\n' $(DEB_SOURCE) $(DEB_VERSION_SOURCE)
+# Use DEB_VERSION_SOURCE to allow binNMU
+ printf >$@ 'Source: %s\nVersion: %s\n' $(DEB_SOURCE) $(DEB_VERSION)
debian/control debian/rules.gen: debian/bin/gencontrol.py $(CONTROL_FILES)
ifeq ($(wildcard debian/control.md5sum),)