summaryrefslogtreecommitdiffstats
path: root/drivers/gpu/drm/xe/tests/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-05 19:21:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-08-05 19:21:13 +0000
commite67e4ad4b161bd60b9da4c1872a9d77e0cac95fa (patch)
tree5c58f869f31ddb1f7bd6e8bdea269b680b36c5b6 /drivers/gpu/drm/xe/tests/Makefile
parentReleasing progress-linux version 6.8.12-1~progress7.99u1. (diff)
downloadlinux-e67e4ad4b161bd60b9da4c1872a9d77e0cac95fa.tar.xz
linux-e67e4ad4b161bd60b9da4c1872a9d77e0cac95fa.zip
Merging upstream version 6.9.7.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'drivers/gpu/drm/xe/tests/Makefile')
-rw-r--r--drivers/gpu/drm/xe/tests/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/drivers/gpu/drm/xe/tests/Makefile b/drivers/gpu/drm/xe/tests/Makefile
index 39d8a08922..9d1d88af8b 100644
--- a/drivers/gpu/drm/xe/tests/Makefile
+++ b/drivers/gpu/drm/xe/tests/Makefile
@@ -1,10 +1,15 @@
# SPDX-License-Identifier: GPL-2.0
+# "live" kunit tests
obj-$(CONFIG_DRM_XE_KUNIT_TEST) += \
xe_bo_test.o \
xe_dma_buf_test.o \
xe_migrate_test.o \
- xe_mocs_test.o \
+ xe_mocs_test.o
+
+# Normal kunit tests
+obj-$(CONFIG_DRM_XE_KUNIT_TEST) += xe_test.o
+xe_test-y = xe_test_mod.o \
xe_pci_test.o \
xe_rtp_test.o \
xe_wa_test.o