summaryrefslogtreecommitdiffstats
path: root/drivers/pnp/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:27:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:27:49 +0000
commitace9429bb58fd418f0c81d4c2835699bddf6bde6 (patch)
treeb2d64bc10158fdd5497876388cd68142ca374ed3 /drivers/pnp/Makefile
parentInitial commit. (diff)
downloadlinux-ace9429bb58fd418f0c81d4c2835699bddf6bde6.tar.xz
linux-ace9429bb58fd418f0c81d4c2835699bddf6bde6.zip
Adding upstream version 6.6.15.upstream/6.6.15
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'drivers/pnp/Makefile')
-rw-r--r--drivers/pnp/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/drivers/pnp/Makefile b/drivers/pnp/Makefile
new file mode 100644
index 0000000000..71d532f182
--- /dev/null
+++ b/drivers/pnp/Makefile
@@ -0,0 +1,15 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the Linux Plug-and-Play Support.
+#
+
+obj-y := pnp.o
+
+pnp-y := core.o card.o driver.o resource.o manager.o support.o interface.o quirks.o
+
+obj-$(CONFIG_PNPACPI) += pnpacpi/
+obj-$(CONFIG_PNPBIOS) += pnpbios/
+obj-$(CONFIG_ISAPNP) += isapnp/
+
+# pnp_system_init goes after pnpacpi/pnpbios init
+pnp-y += system.o