summaryrefslogtreecommitdiffstats
path: root/fs/iomap/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:27:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-11 08:27:49 +0000
commitace9429bb58fd418f0c81d4c2835699bddf6bde6 (patch)
treeb2d64bc10158fdd5497876388cd68142ca374ed3 /fs/iomap/Makefile
parentInitial commit. (diff)
downloadlinux-ace9429bb58fd418f0c81d4c2835699bddf6bde6.tar.xz
linux-ace9429bb58fd418f0c81d4c2835699bddf6bde6.zip
Adding upstream version 6.6.15.upstream/6.6.15
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'fs/iomap/Makefile')
-rw-r--r--fs/iomap/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/fs/iomap/Makefile b/fs/iomap/Makefile
new file mode 100644
index 0000000000..fc070184b7
--- /dev/null
+++ b/fs/iomap/Makefile
@@ -0,0 +1,17 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
+#
+# Copyright (c) 2019 Oracle.
+# All Rights Reserved.
+#
+
+ccflags-y += -I $(srctree)/$(src) # needed for trace events
+
+obj-$(CONFIG_FS_IOMAP) += iomap.o
+
+iomap-y += trace.o \
+ iter.o
+iomap-$(CONFIG_BLOCK) += buffered-io.o \
+ direct-io.o \
+ fiemap.o \
+ seek.o
+iomap-$(CONFIG_SWAP) += swapfile.o