summaryrefslogtreecommitdiffstats
path: root/arch/sparc/boot/install.sh
diff options
context:
space:
mode:
Diffstat (limited to 'arch/sparc/boot/install.sh')
-rwxr-xr-xarch/sparc/boot/install.sh28
1 files changed, 28 insertions, 0 deletions
diff --git a/arch/sparc/boot/install.sh b/arch/sparc/boot/install.sh
new file mode 100755
index 000000000..4f130f3f3
--- /dev/null
+++ b/arch/sparc/boot/install.sh
@@ -0,0 +1,28 @@
+#!/bin/sh
+#
+# This file is subject to the terms and conditions of the GNU General Public
+# License. See the file "COPYING" in the main directory of this archive
+# for more details.
+#
+# Copyright (C) 1995 by Linus Torvalds
+#
+# Adapted from code in arch/i386/boot/Makefile by H. Peter Anvin
+#
+# "make install" script for SPARC architecture
+#
+# Arguments:
+# $1 - kernel version
+# $2 - kernel image file
+# $3 - kernel map file
+# $4 - default install path (blank if root directory)
+
+if [ -f $4/vmlinuz ]; then
+ mv $4/vmlinuz $4/vmlinuz.old
+fi
+
+if [ -f $4/System.map ]; then
+ mv $4/System.map $4/System.old
+fi
+
+cat $2 > $4/vmlinuz
+cp $3 $4/System.map