summaryrefslogtreecommitdiffstats
path: root/arch/sparc/math-emu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'arch/sparc/math-emu/Makefile')
-rw-r--r--arch/sparc/math-emu/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/arch/sparc/math-emu/Makefile b/arch/sparc/math-emu/Makefile
new file mode 100644
index 000000000..aea805979
--- /dev/null
+++ b/arch/sparc/math-emu/Makefile
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for the FPU instruction emulation.
+#
+
+# suppress all warnings - as math.c produces a lot!
+ccflags-y := -w
+
+obj-y := math_$(BITS).o