summaryrefslogtreecommitdiffstats
path: root/debian/patches/debian/ia64-hardcode-arch-script-output.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/debian/ia64-hardcode-arch-script-output.patch')
-rw-r--r--debian/patches/debian/ia64-hardcode-arch-script-output.patch71
1 files changed, 0 insertions, 71 deletions
diff --git a/debian/patches/debian/ia64-hardcode-arch-script-output.patch b/debian/patches/debian/ia64-hardcode-arch-script-output.patch
deleted file mode 100644
index 79356c490..000000000
--- a/debian/patches/debian/ia64-hardcode-arch-script-output.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-From: dann frazier <dannf@debian.org>
-Subject: Hardcode arch script output
-Date: Mon, 26 Mar 2007 16:30:51 -0600
-Bug-Debian: https://bugs.debian.org/392592
-Forwarded: not-needed
-
-Here's a patch that simply uses hardcoded definitions instead of
-doing the dynamic tests that require architecture-specific scripts.
-
-I don't particularly like this approach because it restricts
-portability and diverts from upstream. But, it is simpler, and this
-really needs to be fixed somehow before etch (along with a rebuild of
-linux-modules-extra-2.6), so I'm willing to live with it if my other
-patch is deemed unacceptable.
-
-My primary concern is that, in the future, the output of these scripts
-will change and we (or our successors) will either not notice or
-forget to update the hardcoded values.
-
-Including the scripts in linux-kbuild will avoid this manual step
-altogether, and allow for the possibility of other archs to provide
-their own scripts in the future.
----
- arch/ia64/Makefile | 17 ++---------------
- 1 file changed, 2 insertions(+), 15 deletions(-)
-
---- a/arch/ia64/Makefile
-+++ b/arch/ia64/Makefile
-@@ -26,16 +26,7 @@ cflags-y := -pipe $(EXTRA) -ffixed-r13 -
- -frename-registers -fno-optimize-sibling-calls
- KBUILD_CFLAGS_KERNEL := -mconstant-gp
-
--GAS_STATUS = $(shell $(srctree)/arch/ia64/scripts/check-gas "$(CC)" "$(OBJDUMP)")
--KBUILD_CPPFLAGS += $(shell $(srctree)/arch/ia64/scripts/toolchain-flags "$(CC)" "$(OBJDUMP)" "$(READELF)")
--
--ifeq ($(GAS_STATUS),buggy)
--$(error Sorry, you need a newer version of the assember, one that is built from \
-- a source-tree that post-dates 18-Dec-2002. You can find a pre-compiled \
-- static binary of such an assembler at: \
-- \
-- ftp://ftp.hpl.hp.com/pub/linux-ia64/gas-030124.tar.gz)
--endif
-+KBUILD_CPPFLAGS += -DHAVE_WORKING_TEXT_ALIGN -DHAVE_MODEL_SMALL_ATTRIBUTE -DHAVE_SERIALIZE_DIRECTIVE
-
- quiet_cmd_gzip = GZIP $@
- cmd_gzip = cat $(real-prereqs) | $(KGZIP) -n -f -9 > $@
-@@ -52,7 +42,7 @@ drivers-y += arch/ia64/pci/ arch/ia64/
-
- PHONY += compressed check
-
--all: compressed unwcheck
-+all: compressed
-
- compressed: vmlinux.gz
-
-@@ -64,9 +54,6 @@ vmlinux.gz: vmlinux.bin FORCE
- vmlinux.bin: vmlinux FORCE
- $(call if_changed,objcopy)
-
--unwcheck: vmlinux
-- -$(Q)READELF=$(READELF) $(PYTHON3) $(srctree)/arch/ia64/scripts/unwcheck.py $<
--
- archheaders:
- $(Q)$(MAKE) $(build)=arch/ia64/kernel/syscalls all
-
-@@ -78,5 +66,4 @@ install: vmlinux.gz
- define archhelp
- echo '* compressed - Build compressed kernel image'
- echo ' install - Install compressed kernel image'
-- echo '* unwcheck - Check vmlinux for invalid unwind info'
- endef