summaryrefslogtreecommitdiffstats
path: root/drivers/cpuidle/governors/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/cpuidle/governors/Makefile')
-rw-r--r--drivers/cpuidle/governors/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/drivers/cpuidle/governors/Makefile b/drivers/cpuidle/governors/Makefile
new file mode 100644
index 0000000000..63abb5393a
--- /dev/null
+++ b/drivers/cpuidle/governors/Makefile
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for cpuidle governors.
+#
+
+obj-$(CONFIG_CPU_IDLE_GOV_LADDER) += ladder.o
+obj-$(CONFIG_CPU_IDLE_GOV_MENU) += menu.o
+obj-$(CONFIG_CPU_IDLE_GOV_TEO) += teo.o
+obj-$(CONFIG_CPU_IDLE_GOV_HALTPOLL) += haltpoll.o