summaryrefslogtreecommitdiffstats
path: root/drivers/crypto/aspeed/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/crypto/aspeed/Makefile')
-rw-r--r--drivers/crypto/aspeed/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/drivers/crypto/aspeed/Makefile b/drivers/crypto/aspeed/Makefile
new file mode 100644
index 0000000000..15862752c0
--- /dev/null
+++ b/drivers/crypto/aspeed/Makefile
@@ -0,0 +1,11 @@
+hace-hash-$(CONFIG_CRYPTO_DEV_ASPEED_HACE_HASH) := aspeed-hace-hash.o
+hace-crypto-$(CONFIG_CRYPTO_DEV_ASPEED_HACE_CRYPTO) := aspeed-hace-crypto.o
+
+obj-$(CONFIG_CRYPTO_DEV_ASPEED) += aspeed_crypto.o
+aspeed_crypto-objs := aspeed-hace.o \
+ $(hace-hash-y) \
+ $(hace-crypto-y)
+
+aspeed_acry-$(CONFIG_CRYPTO_DEV_ASPEED_ACRY) += aspeed-acry.o
+
+obj-$(CONFIG_CRYPTO_DEV_ASPEED) += $(aspeed_acry-y)