summaryrefslogtreecommitdiffstats
path: root/drivers/platform/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/platform/Makefile')
-rw-r--r--drivers/platform/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/drivers/platform/Makefile b/drivers/platform/Makefile
new file mode 100644
index 0000000000..4164017297
--- /dev/null
+++ b/drivers/platform/Makefile
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for linux/drivers/platform
+#
+
+obj-$(CONFIG_X86) += x86/
+obj-$(CONFIG_LOONGARCH) += loongarch/
+obj-$(CONFIG_MELLANOX_PLATFORM) += mellanox/
+obj-$(CONFIG_MIPS) += mips/
+obj-$(CONFIG_OLPC_EC) += olpc/
+obj-$(CONFIG_GOLDFISH) += goldfish/
+obj-$(CONFIG_CHROME_PLATFORMS) += chrome/
+obj-$(CONFIG_SURFACE_PLATFORMS) += surface/