summaryrefslogtreecommitdiffstats
path: root/fs/isofs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'fs/isofs/Makefile')
-rw-r--r--fs/isofs/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/fs/isofs/Makefile b/fs/isofs/Makefile
new file mode 100644
index 000000000..6498fd2b0
--- /dev/null
+++ b/fs/isofs/Makefile
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the Linux isofs filesystem routines.
+#
+
+obj-$(CONFIG_ISO9660_FS) += isofs.o
+
+isofs-objs-y := namei.o inode.o dir.o util.o rock.o export.o
+isofs-objs-$(CONFIG_JOLIET) += joliet.o
+isofs-objs-$(CONFIG_ZISOFS) += compress.o
+isofs-objs := $(isofs-objs-y)