summaryrefslogtreecommitdiffstats
path: root/fs/netfs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'fs/netfs/Makefile')
-rw-r--r--fs/netfs/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/fs/netfs/Makefile b/fs/netfs/Makefile
new file mode 100644
index 000000000..386d6fb92
--- /dev/null
+++ b/fs/netfs/Makefile
@@ -0,0 +1,12 @@
+# SPDX-License-Identifier: GPL-2.0
+
+netfs-y := \
+ buffered_read.o \
+ io.o \
+ iterator.o \
+ main.o \
+ objects.o
+
+netfs-$(CONFIG_NETFS_STATS) += stats.o
+
+obj-$(CONFIG_NETFS_SUPPORT) := netfs.o