summaryrefslogtreecommitdiffstats
path: root/fs/orangefs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'fs/orangefs/Makefile')
-rw-r--r--fs/orangefs/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/fs/orangefs/Makefile b/fs/orangefs/Makefile
new file mode 100644
index 000000000..9b6c50bb1
--- /dev/null
+++ b/fs/orangefs/Makefile
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the ORANGEFS filesystem.
+#
+
+obj-$(CONFIG_ORANGEFS_FS) += orangefs.o
+
+orangefs-objs := acl.o file.o orangefs-cache.o orangefs-utils.o xattr.o \
+ dcache.o inode.o orangefs-sysfs.o orangefs-mod.o super.o \
+ devorangefs-req.o namei.o symlink.o dir.o orangefs-bufmap.o \
+ orangefs-debugfs.o waitqueue.o