summaryrefslogtreecommitdiffstats
path: root/kernel/gcov/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'kernel/gcov/Makefile')
-rw-r--r--kernel/gcov/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/kernel/gcov/Makefile b/kernel/gcov/Makefile
new file mode 100644
index 000000000..ccd02afae
--- /dev/null
+++ b/kernel/gcov/Makefile
@@ -0,0 +1,8 @@
+# SPDX-License-Identifier: GPL-2.0
+ccflags-y := -DSRCTREE='"$(srctree)"' -DOBJTREE='"$(objtree)"'
+
+obj-y := base.o fs.o
+obj-$(CONFIG_CC_IS_GCC) += gcc_base.o gcc_4_7.o
+CFLAGS_gcc_base.o += -Wno-missing-prototypes -Wno-missing-declarations
+obj-$(CONFIG_CC_IS_CLANG) += clang.o
+CFLAGS_clang.o += -Wno-missing-prototypes -Wno-missing-declarations