summaryrefslogtreecommitdiffstats
path: root/kernel/printk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'kernel/printk/Makefile')
-rw-r--r--kernel/printk/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/kernel/printk/Makefile b/kernel/printk/Makefile
new file mode 100644
index 000000000..f5b388e81
--- /dev/null
+++ b/kernel/printk/Makefile
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: GPL-2.0-only
+obj-y = printk.o
+obj-$(CONFIG_PRINTK) += printk_safe.o
+obj-$(CONFIG_A11Y_BRAILLE_CONSOLE) += braille.o
+obj-$(CONFIG_PRINTK_INDEX) += index.o
+
+obj-$(CONFIG_PRINTK) += printk_support.o
+printk_support-y := printk_ringbuffer.o
+printk_support-$(CONFIG_SYSCTL) += sysctl.o