summaryrefslogtreecommitdiffstats
path: root/lib/math/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lib/math/Makefile')
-rw-r--r--lib/math/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/lib/math/Makefile b/lib/math/Makefile
new file mode 100644
index 000000000..91fcdb0c9
--- /dev/null
+++ b/lib/math/Makefile
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: GPL-2.0-only
+obj-y += div64.o gcd.o lcm.o int_log.o int_pow.o int_sqrt.o reciprocal_div.o
+
+obj-$(CONFIG_CORDIC) += cordic.o
+obj-$(CONFIG_PRIME_NUMBERS) += prime_numbers.o
+obj-$(CONFIG_RATIONAL) += rational.o
+
+obj-$(CONFIG_TEST_DIV64) += test_div64.o
+obj-$(CONFIG_RATIONAL_KUNIT_TEST) += rational-test.o