summaryrefslogtreecommitdiffstats
path: root/net/mpls/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/mpls/Makefile')
-rw-r--r--net/mpls/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/net/mpls/Makefile b/net/mpls/Makefile
new file mode 100644
index 000000000..53e33b6c7
--- /dev/null
+++ b/net/mpls/Makefile
@@ -0,0 +1,9 @@
+# SPDX-License-Identifier: GPL-2.0-only
+#
+# Makefile for MPLS.
+#
+obj-$(CONFIG_NET_MPLS_GSO) += mpls_gso.o
+obj-$(CONFIG_MPLS_ROUTING) += mpls_router.o
+obj-$(CONFIG_MPLS_IPTUNNEL) += mpls_iptunnel.o
+
+mpls_router-y := af_mpls.o