summaryrefslogtreecommitdiffstats
path: root/net/unix/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/unix/Makefile')
-rw-r--r--net/unix/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/net/unix/Makefile b/net/unix/Makefile
new file mode 100644
index 000000000..20491825b
--- /dev/null
+++ b/net/unix/Makefile
@@ -0,0 +1,15 @@
+# SPDX-License-Identifier: GPL-2.0
+#
+# Makefile for the Linux unix domain socket layer.
+#
+
+obj-$(CONFIG_UNIX) += unix.o
+
+unix-y := af_unix.o garbage.o
+unix-$(CONFIG_SYSCTL) += sysctl_net_unix.o
+unix-$(CONFIG_BPF_SYSCALL) += unix_bpf.o
+
+obj-$(CONFIG_UNIX_DIAG) += unix_diag.o
+unix_diag-y := diag.o
+
+obj-$(CONFIG_UNIX_SCM) += scm.o