summaryrefslogtreecommitdiffstats
path: root/tools/crypto/ccp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/crypto/ccp/Makefile')
-rw-r--r--tools/crypto/ccp/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/tools/crypto/ccp/Makefile b/tools/crypto/ccp/Makefile
new file mode 100644
index 0000000000..ae4a66d155
--- /dev/null
+++ b/tools/crypto/ccp/Makefile
@@ -0,0 +1,13 @@
+# SPDX-License-Identifier: GPL-2.0-only
+CFLAGS += -D__EXPORTED_HEADERS__ -I../../../include/uapi -I../../../include
+
+TARGET = dbc_library.so
+
+all: $(TARGET)
+
+dbc_library.so: dbc.c
+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -o $@ $<
+ chmod -x $@
+
+clean:
+ $(RM) $(TARGET)