summaryrefslogtreecommitdiffstats
path: root/tools/net/ynl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/net/ynl/Makefile')
-rw-r--r--tools/net/ynl/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/tools/net/ynl/Makefile b/tools/net/ynl/Makefile
new file mode 100644
index 000000000..8156f03e2
--- /dev/null
+++ b/tools/net/ynl/Makefile
@@ -0,0 +1,20 @@
+# SPDX-License-Identifier: GPL-2.0
+
+SUBDIRS = lib generated samples
+
+all: $(SUBDIRS)
+ ./ynl-regen.sh -f -p $(PWD)/../../../
+
+$(SUBDIRS):
+ @if [ -f "$@/Makefile" ] ; then \
+ $(MAKE) -C $@ ; \
+ fi
+
+clean hardclean:
+ @for dir in $(SUBDIRS) ; do \
+ if [ -f "$$dir/Makefile" ] ; then \
+ $(MAKE) -C $$dir $@; \
+ fi \
+ done
+
+.PHONY: clean all $(SUBDIRS)