summaryrefslogtreecommitdiffstats
path: root/tools/testing/selftests/damon/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tools/testing/selftests/damon/Makefile')
-rw-r--r--tools/testing/selftests/damon/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/tools/testing/selftests/damon/Makefile b/tools/testing/selftests/damon/Makefile
new file mode 100644
index 0000000000..b71247ba71
--- /dev/null
+++ b/tools/testing/selftests/damon/Makefile
@@ -0,0 +1,14 @@
+# SPDX-License-Identifier: GPL-2.0
+# Makefile for damon selftests
+
+TEST_GEN_FILES += huge_count_read_write
+
+TEST_FILES = _chk_dependency.sh _debugfs_common.sh
+TEST_PROGS = debugfs_attrs.sh debugfs_schemes.sh debugfs_target_ids.sh
+TEST_PROGS += debugfs_empty_targets.sh debugfs_huge_count_read_write.sh
+TEST_PROGS += debugfs_duplicate_context_creation.sh
+TEST_PROGS += debugfs_rm_non_contexts.sh
+TEST_PROGS += sysfs.sh sysfs_update_removed_scheme_dir.sh
+TEST_PROGS += reclaim.sh lru_sort.sh
+
+include ../lib.mk