summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..4e2e2d1
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+# Produce no debug information for mipsel builds
+# to avoid FTBFS due to running out of memory,
+# cf. #1021665
+ifneq (,$(filter $(DEB_HOST_ARCH), mipsel))
+ export DEB_CXXFLAGS_MAINT_APPEND = -g0
+endif
+
+%:
+ dh $@
+
+override_dh_auto_configure:
+ dh_auto_configure -- --disable-static
+
+override_dh_installchangelogs:
+ dh_installchangelogs NEWS.md