summaryrefslogtreecommitdiffstats
path: root/.vscode/settings.json
diff options
context:
space:
mode:
Diffstat (limited to '.vscode/settings.json')
-rw-r--r--.vscode/settings.json23
1 files changed, 23 insertions, 0 deletions
diff --git a/.vscode/settings.json b/.vscode/settings.json
new file mode 100644
index 0000000..9df63e5
--- /dev/null
+++ b/.vscode/settings.json
@@ -0,0 +1,23 @@
+{
+ "files.exclude": {
+ "**/.git": true,
+ "**/__pycache__": true,
+ "**/.mypy_cache": true,
+ "**/.pytest_cache": true,
+ "**/.nox": true
+ },
+ "python.formatting.provider": "none",
+ "editor.formatOnSave": true,
+ "editor.codeActionsOnSave": {
+ "source.organizeImports": true
+ },
+ "[python]": {
+ "editor.defaultFormatter": "ms-python.black-formatter"
+ },
+ "isort.args": ["--profile", "black"],
+ "python.testing.pytestArgs": ["tests"],
+ "python.testing.unittestEnabled": false,
+ "python.testing.pytestEnabled": true,
+ "python.analysis.extraPaths": ["packages/python", "tests/python/common"],
+ "rust-analyzer.linkedProjects": ["packages/rust/lsprotocol/Cargo.toml"]
+}