summaryrefslogtreecommitdiffstats
path: root/packages/rust/lsprotocol/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'packages/rust/lsprotocol/Cargo.toml')
-rw-r--r--packages/rust/lsprotocol/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/packages/rust/lsprotocol/Cargo.toml b/packages/rust/lsprotocol/Cargo.toml
new file mode 100644
index 0000000..4d1ddc9
--- /dev/null
+++ b/packages/rust/lsprotocol/Cargo.toml
@@ -0,0 +1,16 @@
+[package]
+name = "lsprotocol"
+version = "0.1.0"
+edition = "2021"
+description = "Rust implementation of the Language Server Protocol generated from LSP specification."
+authors = ["Microsoft Corporation <lsprotocol-help@microsoft.com>", "Karthik Nadig <kanadig@microsoft.com>"]
+license = "MIT"
+repository = "https://github.com/microsoft/lsprotocol"
+readme = "README.md"
+
+[dependencies]
+serde = {version ="1.0.152", features = ["derive"]}
+serde_json = "1.0.93"
+serde_repr = "0.1.10"
+url = "2.3.1"
+rust_decimal = "1.29.1"