summaryrefslogtreecommitdiffstats
path: root/share/mk/configure/link_pages.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 19:41:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 19:41:09 +0000
commit0db324e2e5d9d3347ea0e93138372fb65aac09e6 (patch)
tree1b794022fb98db123c73021e75286a82c116aa7f /share/mk/configure/link_pages.mk
parentReleasing progress-linux version 6.05.01-1~progress7.99u1. (diff)
downloadmanpages-0db324e2e5d9d3347ea0e93138372fb65aac09e6.tar.xz
manpages-0db324e2e5d9d3347ea0e93138372fb65aac09e6.zip
Merging upstream version 6.7.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'share/mk/configure/link_pages.mk')
-rw-r--r--share/mk/configure/link_pages.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/share/mk/configure/link_pages.mk b/share/mk/configure/link_pages.mk
new file mode 100644
index 0000000..52136ef
--- /dev/null
+++ b/share/mk/configure/link_pages.mk
@@ -0,0 +1,18 @@
+# Copyright 2023-2024, Alejandro Colomar <alx@kernel.org>
+# SPDX-License-Identifier: LGPL-3.0-only WITH LGPL-3.0-linking-exception
+
+
+ifndef MAKEFILE_CONFIGURE_LINK_PAGES_INCLUDED
+MAKEFILE_CONFIGURE_LINK_PAGES_INCLUDED := 1
+
+
+LINK_PAGES := .so
+ifeq ($(LINK_PAGES),.so)
+else ifeq ($(LINK_PAGES),symlink)
+else
+$(warning "LINK_PAGES": "$(LINK_PAGES)")
+$(error Valid values for "LINK_PAGES": [".so", "symlink"])
+endif
+
+
+endif # include guard