summaryrefslogtreecommitdiffstats
path: root/share/mk/lint/c/_.mk
diff options
context:
space:
mode:
Diffstat (limited to 'share/mk/lint/c/_.mk')
-rw-r--r--share/mk/lint/c/_.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/share/mk/lint/c/_.mk b/share/mk/lint/c/_.mk
new file mode 100644
index 0000000..dc2f3e2
--- /dev/null
+++ b/share/mk/lint/c/_.mk
@@ -0,0 +1,18 @@
+# Copyright 2021-2024, Alejandro Colomar <alx@kernel.org>
+# SPDX-License-Identifier: LGPL-3.0-only WITH LGPL-3.0-linking-exception
+
+
+ifndef MAKEFILE_LINT_C_INCLUDED
+MAKEFILE_LINT_C_INCLUDED := 1
+
+
+.PHONY: lint-c
+lint-c: \
+ lint-c-checkpatch \
+ lint-c-clang-tidy \
+ lint-c-cppcheck \
+ lint-c-cpplint \
+ lint-c-iwyu
+
+
+endif # include guard