summaryrefslogtreecommitdiffstats
path: root/share/mk/lint/c/cpplint.mk
diff options
context:
space:
mode:
Diffstat (limited to 'share/mk/lint/c/cpplint.mk')
-rw-r--r--share/mk/lint/c/cpplint.mk13
1 files changed, 9 insertions, 4 deletions
diff --git a/share/mk/lint/c/cpplint.mk b/share/mk/lint/c/cpplint.mk
index 8eb3984..5e07488 100644
--- a/share/mk/lint/c/cpplint.mk
+++ b/share/mk/lint/c/cpplint.mk
@@ -7,14 +7,19 @@ MAKEFILE_LINT_C_CPPLINT_INCLUDED := 1
include $(MAKEFILEDIR)/build/examples/src.mk
-include $(MAKEFILEDIR)/configure/build-depends/coreutils.mk
-include $(MAKEFILEDIR)/configure/build-depends/cpplint.mk
+include $(MAKEFILEDIR)/configure/build-depends/coreutils/touch.mk
+include $(MAKEFILEDIR)/configure/build-depends/cpplint/cpplint.mk
-_LINT_c_cpplint := $(patsubst %.c, %.lint-c.cpplint.touch, $(_UNITS_ex_c))
+_LINT_c_EX_cpplint := $(patsubst %, %.lint-c.cpplint.touch, $(_EX_TU_src))
+_LINT_c_cpplint := $(_LINT_c_EX_cpplint)
-$(_LINT_c_cpplint): %.lint-c.cpplint.touch: %.c $(CPPLINT_CONF) $(MK)
+$(_LINT_c_EX_cpplint): %.lint-c.cpplint.touch: %
+$(_LINT_c_cpplint): $(CPPLINT_CONF) $(MK) | $$(@D)/
+
+
+$(_LINT_c_cpplint):
$(info $(INFO_)CPPLINT $@)
$(CPPLINT) $(CPPLINTFLAGS) $< >/dev/null
$(TOUCH) $@