summaryrefslogtreecommitdiffstats
path: root/share/mk/lint/man/tbl.mk
diff options
context:
space:
mode:
Diffstat (limited to 'share/mk/lint/man/tbl.mk')
-rw-r--r--share/mk/lint/man/tbl.mk48
1 files changed, 26 insertions, 22 deletions
diff --git a/share/mk/lint/man/tbl.mk b/share/mk/lint/man/tbl.mk
index 23e6eda..cb2dd46 100644
--- a/share/mk/lint/man/tbl.mk
+++ b/share/mk/lint/man/tbl.mk
@@ -6,34 +6,38 @@ ifndef MAKEFILE_LINT_MAN_TBL_INCLUDED
MAKEFILE_LINT_MAN_TBL_INCLUDED := 1
-include $(MAKEFILEDIR)/build/_.mk
-include $(MAKEFILEDIR)/configure/build-depends/coreutils.mk
-include $(MAKEFILEDIR)/configure/build-depends/grep.mk
-include $(MAKEFILEDIR)/configure/src.mk
-include $(MAKEFILEDIR)/lint/man/_.mk
-include $(MAKEFILEDIR)/src.mk
+include $(MAKEFILEDIR)/build/man/man.mk
+include $(MAKEFILEDIR)/configure/build-depends/coreutils/cat.mk
+include $(MAKEFILEDIR)/configure/build-depends/coreutils/echo.mk
+include $(MAKEFILEDIR)/configure/build-depends/coreutils/head.mk
+include $(MAKEFILEDIR)/configure/build-depends/coreutils/tail.mk
+include $(MAKEFILEDIR)/configure/build-depends/coreutils/touch.mk
+include $(MAKEFILEDIR)/configure/build-depends/grep/grep.mk
-_LINT_man_tbl := \
- $(patsubst $(MANDIR)/%, $(_MANDIR)/%.lint-man.tbl.touch, $(NONSO_MAN))
+_LINT_man_tbl := $(patsubst %, %.lint-man.tbl.touch, $(_NONSO_MAN))
-$(_LINT_man_tbl): $(_MANDIR)/%.lint-man.tbl.touch: $(MANDIR)/% $(MK) | $$(@D)/
+$(_LINT_man_tbl): %.lint-man.tbl.touch: % $(MK) | $$(@D)/
$(info $(INFO_)GREP $@)
- if $(GREP) -q '^\.TS$$' $< && ! $(HEAD) -n1 $< | $(GREP) -q '\\" t$$'; \
- then \
- >&2 $(ECHO) "$<:1: missing '\\\" t' comment:"; \
- >&2 $(HEAD) -n1 <$<; \
- exit 1; \
- fi
- if $(HEAD) -n1 $< | $(GREP) -q '\\" t$$' && ! $(GREP) -q '^\.TS$$' $<; \
- then \
- >&2 $(ECHO) "$<:1: spurious '\\\" t' comment:"; \
- >&2 $(HEAD) -n1 <$<; \
- exit 1; \
+ $(HEAD) -n1 <$< \
+ | if $(GREP) '\\" t$$' >/dev/null; then \
+ $(CAT) <$< \
+ | if ! $(GREP) '^\.TS$$' >/dev/null; then \
+ >&2 $(ECHO) "$<:1: spurious '\\\" t' comment:"; \
+ >&2 $(HEAD) -n1 <$<; \
+ exit 1; \
+ fi; \
+ else \
+ $(CAT) <$< \
+ | if $(GREP) '^\.TS$$' >/dev/null; then \
+ >&2 $(ECHO) "$<:1: missing '\\\" t' comment:"; \
+ >&2 $(HEAD) -n1 <$<; \
+ exit 1; \
+ fi; \
fi
- if $(TAIL) -n+2 <$< | $(GREP) -q '\\" t$$'; \
- then \
+ $(TAIL) -n+2 <$< \
+ | if $(GREP) '\\" t$$' >/dev/null; then \
>&2 $(ECHO) "$<: spurious '\\\" t' not in first line:"; \
>&2 $(GREP) -n '\\" t$$' $< /dev/null; \
exit 1; \