summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-07-01 18:15:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-07-01 18:15:13 +0000
commit85c88fe6f1d622d10f5ac2d747412cb90f5cf150 (patch)
tree310fa21dd40d6c7ad918d0771b5f03c378d54cc6 /debian/patches
parentMerging upstream version 1:11.4.2. (diff)
downloadmariadb-progress-linux.tar.xz
mariadb-progress-linux.zip
Merging debian version 1:11.4.2-1.HEADprogress-linux
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org> debian/control debian/libmariadbd19.install debian/libmariadbd19.lintian-overrides debian/salsa-ci.yml
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/fix-spelling-mariadb.patch37
-rw-r--r--debian/patches/startup-message.patch4
2 files changed, 36 insertions, 5 deletions
diff --git a/debian/patches/fix-spelling-mariadb.patch b/debian/patches/fix-spelling-mariadb.patch
index 5d5265cb..b5695be5 100644
--- a/debian/patches/fix-spelling-mariadb.patch
+++ b/debian/patches/fix-spelling-mariadb.patch
@@ -45,7 +45,7 @@ Subject: [PATCH] Fix misc spelling in MariaDB Server repository
in milliseconds (default is 1 second) */
ulint xtrabackup_log_copy_interval = 1000;
static ulong max_buf_pool_modified_pct;
-@@ -1597,11 +1597,11 @@ struct my_option xb_client_options[]= {
+@@ -1600,11 +1600,11 @@ struct my_option xb_client_options[]= {
GET_BOOL, NO_ARG, 0, 0, 0, 0, 0, 0},
{"rsync", OPT_RSYNC,
@@ -59,7 +59,7 @@ Subject: [PATCH] Fix misc spelling in MariaDB Server repository
&ignored_option, &ignored_option, 0, GET_BOOL, NO_ARG, 0, 0, 0, 0, 0, 0},
{"force-non-empty-directories", OPT_FORCE_NON_EMPTY_DIRS,
-@@ -1729,7 +1729,7 @@ struct my_option xb_client_options[]= {
+@@ -1732,7 +1732,7 @@ struct my_option xb_client_options[]= {
{"startup-wait-timeout", OPT_LOCK_WAIT_TIMEOUT,
"This option specifies time in seconds that mariadb-backup should wait for "
"BACKUP STAGE START to complete. BACKUP STAGE START has to wait until all "
@@ -68,7 +68,7 @@ Subject: [PATCH] Fix misc spelling in MariaDB Server repository
"If there are still such queries when the timeout expires, mariadb-backup "
"terminates with an error. Default is 0, in which case mariadb-backup waits "
"indefinitely for BACKUP STAGE START to finish",
-@@ -5622,7 +5622,7 @@ void CorruptedPages::backup_fix_ddl(ds_c
+@@ -5642,7 +5642,7 @@ void CorruptedPages::backup_fix_ddl(ds_c
}
/* Mariabackup doesn't detect any FILE_OP for the deferred
@@ -88,3 +88,34 @@ Subject: [PATCH] Fix misc spelling in MariaDB Server repository
#
extra_args=""
+--- a/sql/opt_subselect.cc
++++ b/sql/opt_subselect.cc
+@@ -6886,7 +6886,7 @@ bool JOIN::choose_subquery_plan(table_ma
+ add("rows", inner_record_count_1).
+ add("materialization_cost", materialize_strategy_cost).
+ add("in_exist_cost", in_exists_strategy_cost).
+- add("choosen", strategy);
++ add("chosen", strategy);
+ }
+
+ DBUG_PRINT("info",
+@@ -6924,7 +6924,7 @@ bool JOIN::choose_subquery_plan(table_ma
+ {
+ Json_writer_object trace_wrapper(thd);
+ Json_writer_object trace_subquery(thd, "subquery_plan_revert");
+- trace_subquery.add("choosen", "in_to_exists");
++ trace_subquery.add("chosen", "in_to_exists");
+ }
+ }
+
+--- a/sql/sql_select.cc
++++ b/sql/sql_select.cc
+@@ -14670,7 +14670,7 @@ void JOIN::drop_unused_derived_keys()
+ }
+ /*
+ We dropped all keys except the chosen one and unique keys.
+- The choosen one is stored as the first key (number 0).
++ The chosen one is stored as the first key (number 0).
+ */
+ tab->ref.key= 0;
+ }
diff --git a/debian/patches/startup-message.patch b/debian/patches/startup-message.patch
index 6b8bbce7..5c4994a4 100644
--- a/debian/patches/startup-message.patch
+++ b/debian/patches/startup-message.patch
@@ -27,7 +27,7 @@ Server output if build in git directory:
--- a/client/mysql.cc
+++ b/client/mysql.cc
-@@ -1328,6 +1328,9 @@ int main(int argc,char *argv[])
+@@ -1333,6 +1333,9 @@ int main(int argc,char *argv[])
mysql_thread_id(&mysql), server_version_string(&mysql));
put_info((char*) glob_buffer.ptr(),INFO_INFO);
put_info(ORACLE_WELCOME_COPYRIGHT_NOTICE("2000"), INFO_INFO);
@@ -39,7 +39,7 @@ Server output if build in git directory:
#ifdef HAVE_READLINE
--- a/sql/mysqld.cc
+++ b/sql/mysqld.cc
-@@ -4985,12 +4985,21 @@ static int init_server_components()
+@@ -4932,12 +4932,21 @@ static int init_server_components()
my_sleep_for_space= mariadb_sleep_for_space;
/*