summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 12 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 45c74f74..94eb814f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -80,10 +80,10 @@ override_dh_auto_clean:
rm -rf storage/columnstore
# Delete precompiled binaries in upstream sources to ensure they are not used in Debian
rm -rf storage/connect/JavaWrappers.jar storage/columnstore/columnstore/utils/jemalloc/libjemalloc.so.2
-
+
# Update po-files when clean runs before each build
debconf-updatepo
-
+
# Clean up files created by custom sections in build that 'dh clean' does not see automatically
rm -rf debian/mariadb-server.*.socket debian/substvars
@@ -122,6 +122,7 @@ endif
-DIGNORE_AIO_CHECK=ON \
-DWITH_URING=ON \
-DWITH_INNODB_SNAPPY=ON \
+ -DHAVE_SYSTEM_LIBFMT_EXITCODE=0 \
-DDEB=$(DEB_VENDOR)
# This is needed, otherwise 'make test' will run before binaries have been built
@@ -204,8 +205,17 @@ override_dh_auto_install:
# Move test plugins that are only needed by the client to the libmariadb path
mv -v $(TMP)/usr/lib/mysql/plugin/qa_auth_client.so $(TMP)/usr/lib/$(DEB_HOST_MULTIARCH)/libmariadb3/plugin/
+# Define name used for service, and install mariadb.service on Linux only
override_dh_installsystemd:
+ifneq (,$(filter linux,$(DEB_HOST_ARCH_OS)))
dh_installsystemd -pmariadb-server mariadb.service
+endif
+
+# Change dh_missing from fail to list on non-Linux
+override_dh_missing:
+ifneq (,$(filter linux,$(DEB_HOST_ARCH_OS)))
+ dh_missing --list-missing
+endif
override_dh_installinit-arch:
dh_installinit --name=mariadb