summaryrefslogtreecommitdiffstats
path: root/libservices
diff options
context:
space:
mode:
Diffstat (limited to 'libservices')
-rw-r--r--libservices/CMakeLists.txt1
-rw-r--r--libservices/print_check_msg_service.c18
2 files changed, 19 insertions, 0 deletions
diff --git a/libservices/CMakeLists.txt b/libservices/CMakeLists.txt
index 8c559cb0..37c24646 100644
--- a/libservices/CMakeLists.txt
+++ b/libservices/CMakeLists.txt
@@ -25,6 +25,7 @@ SET(MYSQLSERVICES_SOURCES
my_crypt_service.c
my_md5_service.c
my_print_error_service.c
+ print_check_msg_service.c
my_sha1_service.c
my_sha2_service.c
my_snprintf_service.c
diff --git a/libservices/print_check_msg_service.c b/libservices/print_check_msg_service.c
new file mode 100644
index 00000000..12f7bc51
--- /dev/null
+++ b/libservices/print_check_msg_service.c
@@ -0,0 +1,18 @@
+/* Copyright (c) 2024, MariaDB Plc
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; version 2 of the License.
+
+ This program is distributed in the hope that it will be useful, but
+ WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+*/
+
+#include <service_versions.h>
+SERVICE_VERSION print_check_msg_context= (void*) VERSION_print_check_msg;