summaryrefslogtreecommitdiffstats
path: root/plugin/provider_lz4
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/provider_lz4')
-rw-r--r--plugin/provider_lz4/CMakeLists.txt15
-rw-r--r--plugin/provider_lz4/plugin.c56
-rw-r--r--plugin/provider_lz4/provider_lz4.cnf3
3 files changed, 74 insertions, 0 deletions
diff --git a/plugin/provider_lz4/CMakeLists.txt b/plugin/provider_lz4/CMakeLists.txt
new file mode 100644
index 00000000..daad63ac
--- /dev/null
+++ b/plugin/provider_lz4/CMakeLists.txt
@@ -0,0 +1,15 @@
+FIND_PACKAGE(LZ4 1.6)
+
+SET(CPACK_RPM_provider-lz4_PACKAGE_SUMMARY "LZ4 compression support in the server and storage engines" PARENT_SCOPE)
+SET(CPACK_RPM_provider-lz4_PACKAGE_DESCRIPTION "LZ4 compression support in the server and storage engines" PARENT_SCOPE)
+
+IF (LZ4_FOUND)
+ GET_PROPERTY(dirs DIRECTORY PROPERTY INCLUDE_DIRECTORIES)
+ LIST(REMOVE_ITEM dirs ${CMAKE_SOURCE_DIR}/include/providers)
+ SET_PROPERTY(DIRECTORY PROPERTY INCLUDE_DIRECTORIES "${dirs}")
+
+ INCLUDE_DIRECTORIES(${LZ4_INCLUDE_DIRS})
+
+ MYSQL_ADD_PLUGIN(provider_lz4 plugin.c COMPONENT provider-lz4
+ LINK_LIBRARIES ${LZ4_LIBRARIES} CONFIG provider_lz4.cnf)
+ENDIF()
diff --git a/plugin/provider_lz4/plugin.c b/plugin/provider_lz4/plugin.c
new file mode 100644
index 00000000..f9eab163
--- /dev/null
+++ b/plugin/provider_lz4/plugin.c
@@ -0,0 +1,56 @@
+/* Copyright (c) 2021, MariaDB Corporation
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; version 2 of the License.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1335 USA */
+
+#include <stdbool.h>
+#include <mysql_version.h>
+#include <mysql/plugin.h>
+#include <lz4.h>
+#include <providers/lz4.h>
+
+static int init(void* h)
+{
+ provider_service_lz4->LZ4_compressBound_ptr= LZ4_compressBound;
+ provider_service_lz4->LZ4_compress_default_ptr= LZ4_compress_default;
+ provider_service_lz4->LZ4_decompress_safe_ptr= LZ4_decompress_safe;
+
+ provider_service_lz4->is_loaded = true;
+
+ return 0;
+}
+
+static int deinit(void *h)
+{
+ return 1; /* don't unload me */
+}
+
+static struct st_mysql_daemon info= { MYSQL_DAEMON_INTERFACE_VERSION };
+
+maria_declare_plugin(provider_lz4)
+{
+ MYSQL_DAEMON_PLUGIN,
+ &info,
+ "provider_lz4",
+ "Kartik Soneji",
+ "LZ4 compression provider",
+ PLUGIN_LICENSE_GPL,
+ init,
+ deinit,
+ 0x0100,
+ NULL,
+ NULL,
+ "1.0",
+ MariaDB_PLUGIN_MATURITY_STABLE
+}
+maria_declare_plugin_end;
diff --git a/plugin/provider_lz4/provider_lz4.cnf b/plugin/provider_lz4/provider_lz4.cnf
new file mode 100644
index 00000000..0b8a3ec5
--- /dev/null
+++ b/plugin/provider_lz4/provider_lz4.cnf
@@ -0,0 +1,3 @@
+[server]
+plugin_load_add=provider_lz4
+provider_lz4=force_plus_permanent